View Full Version : 06 Suspension Fault issue


moredirtpoor
11-23-2005, 09:51 AM
Hi and I am new. I just bought my LR3 Saturday and by monday I got the System fault error message. It seemed to go away when I continued driving but it appeared again this morning on my way to work. I believe that someone asked if the issue had been rectified in the '06 models. We will see.....

grommet
11-23-2005, 07:41 PM
In summary, there are barely any differences between 2005 and 2006... any "changes" or fixes in production happen no matter what the model year is. In theory, the later the build... the more fixes or build improvements. But failure is on it's own schedule...

cunard030
12-01-2005, 10:20 AM
Bought a 2005 LR3 SE V8 in July and experienced my first suspension fault while on vacation. The vehicle was stuck in the access mode and couldn't be driven over 35 mph. The dealer replaced the compressor and I was on my way. Exactly one month later I had another fault while driving at approx 75 mph and the rear of the vehicle dropped and the front stayed level. The dealer had the LR3 for a week I picked it up and it faulted again one block from the dealer. They had it another week and I picked it up on a friday and on Saturday morning it faulted at a stop light. They had it another week and I picked it up and within 45 minutes it faulted again for the 5th time. I see many of you have had the same issues. Has anyone been successful with a buyback from Land Rover? I do not want another LR3. I just want my $$ back.

askewed
12-01-2005, 10:40 AM
I just want my $$ back.


They'll do it... They bought mine back (I took another one). You need to call LRNA get a good csr and document all of your experiences. They want to avoid the truck being a lemon very badly! Don't mention lemon if you can avoid it. Ask them to buy it back... I get the feeling from my rep that they're buying back quite a few...

mike01
12-01-2005, 12:22 PM
This suspension issue has me thinking. There are so many LR3s out there with no suspension problems at all (most of them, in fact), a small minority with non-recurring faults, and then there are cars like ones described here, where no matter what the dealer does, the problem keeps reoccuring.

The only possible explanation is either a) the dealer is compeltely incompetend and instead of fixing the underlying problem (which they probably can't find) simply resets the computer, so that the suspension will fault when the unfixed problem manifests itself, or b) the dealer replaces a component that failed but fails to correct the problem that caused the component to fail in the first place, which means that the new component will just fail again just like the old one did.

I just got my 05 SE V8 and so far I don't have any problems, but the air suspension thing has me a little nervous. It's good to realize that the vast majority of these vehicles don't ever have this problem. I spoke to a technician at my dealer (they're a good dealer) and he said he's seen 5 of them since the model started selling and none of them has ever come back for the same problem.

It seems to me some dealers don't know enough about the suspension. Any thoughts?

ralphp
12-01-2005, 12:51 PM
Hi and I am new. I just bought my LR3 Saturday and by monday I got the System fault error message. It seemed to go away when I continued driving but it appeared again this morning on my way to work. I believe that someone asked if the issue had been rectified in the '06 models. We will see.....

Hi i've got the same prolbme on an 05 lr3. it's been to three dealers and in the shop 40 days out of last 90. i trying to get them to buy back. talked with executive office in new york, plus regional manager on west coast.
let see what they do with this lemon

askewed
12-01-2005, 01:01 PM
b) the dealer replaces a component that failed but fails to correct the problem that caused the component to fail in the first place, which means that the new component will just fail again just like the old one did.


My 2nd compressor on my first LR3 - that's when your "b" first occurred to me. I got the compressor from the regional service guys truck (6000miles no issues) and it went bad on me in less then a week. The compressor isn't the problem it's a symptom.

40 days in the shop + suspension issues equal LEMON! Just tell them you'd like to avoid the L.L. process (as you're sure they'd like to do)... could they please buy it back... How many compressors have you had???

Your truck is either a truck they can sell again (thus getting 3 more chances to fix it) or right off as a loss... They don't want that!

flowner
12-02-2005, 07:36 AM
Has anyone had the 06 had a complete compressor failure where the car is stuck in access mode? I guess if not that's an improvement over the 05'S. There was a tread on the UK site mentioning that some suspensions failure were cause be problems with the cross valve that stress the compressor.

porsche3
12-03-2005, 07:18 PM
After 2300 miles, our 06 v6 showed suspension fault. So far drivable, and message center is clean after shutting truck down and restarting. Also, after the 1st time yesterday, today on short trips it's been ok. Since my wife uses it and she tends to take short trips, around 20-30miles each time, for errands, wonder it'll happen again.

Will take it into dealer for service, it's not the same dealer we bought the truck from, any info we should tell dealer from other forum members? Appreciate the input.