Go Back   Land Rover and Range Rover Forums > Technical Discussions > Range Rover

Sponsored Ads
Register or log in to remove these ads.

Range Rover technical discussions for the Range Rover


Reply
 
Thread Tools
Old 08-23-2009, 04:21 PM   #1
dfayette
Roverito
 
Join Date: Aug 2009
Posts: 8
Error Codes P0171, P0174, P0734


Register to remove these ads. It's free!
I'm looking for the most likely solution to P0171 and P0174 error codes. Most likely the air pump but how can I prove it?
The error reads lean on bank one, and lean on bank two. I'm guessing the pump has gone bad but not sure how I can know for sure.

Also I've been getting random P0734 codes, which show wrong gear ratio in gear 4. I clear it and it comes back days or weeks later. I suspect something with the rear axle but not sure where to start looking.


dfayette is offline   Reply With Quote
Old 08-23-2009, 06:29 PM   #2
Disco Mike
Full Access Member
 
Disco Mike's Avatar
 
Join Date: Jun 2009
Posts: 1,882
Those codes are an indicator of a failed MAF. How often do you change your air filter, are you using a paper of a K&N type air filter? If K&N, get rid of it.
__________________
Mike

I am a retired service manager of 30 years, currently driving a 99 D2 with the following mods.
Custom made front and rear bumpers, Warn 9500 HSI with 3/8th's rope, sliders, QT diff. guards, electronic CDL, 4:11 gears, rear Detroit with HD axles, Front T.T., HID head light conversions and 3 extra bumper mounted HIDs.

To download the RAVE manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm
Disco Mike is offline   Reply With Quote
Old 08-26-2009, 12:26 PM   #3
dfayette
Roverito
 
Join Date: Aug 2009
Posts: 8
I don't use K&N on the Range Rover but change the filter every 5K miles since we live in a dusty environment.
Can a dirty filter cause these codes or do I need to replace the MAF?
dfayette is offline   Reply With Quote
Old 08-26-2009, 01:44 PM   #4
Disco Mike
Full Access Member
 
Disco Mike's Avatar
 
Join Date: Jun 2009
Posts: 1,882
Yes it can.
If you have any questions, send me your tele number and I'll call you.
__________________
Mike

I am a retired service manager of 30 years, currently driving a 99 D2 with the following mods.
Custom made front and rear bumpers, Warn 9500 HSI with 3/8th's rope, sliders, QT diff. guards, electronic CDL, 4:11 gears, rear Detroit with HD axles, Front T.T., HID head light conversions and 3 extra bumper mounted HIDs.

To download the RAVE manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm
Disco Mike is offline   Reply With Quote
Old 08-27-2009, 01:32 PM   #5
dfayette
Roverito
 
Join Date: Aug 2009
Posts: 8
Error Codes P0171, P0174 and P0734

My phone number is 425-301-6487

Is there a test for the MAF? I checked the filter and it's not very dirty. I'll replace it anyway. The MAF "looks" good but it would be nice to be able to test it prior to replacement.
dfayette is offline   Reply With Quote
Old 06-18-2010, 10:45 AM   #6
Gold Yeller
Roverito
 
Join Date: Jun 2010
Posts: 2
Annoying MAF faults

Hi dfayette & Disco Mike: I was wondering how you were able to get your problems resolved. I'm having the same issue, somewhat. I own a '99 RR 4.6HSE, all stock except for the replacement K&N air filter. At first, I was getting error codes P0733 and P0734, erased the code. Then, I cleaned the MAF with the MAF spray cleaner. Drove and got 20 miles out before the light came on again, this time stating P0171 and P0174. I'm gonna clean the MAF sensor again, erase the code again. If it happens again, I'm gonna slap on a regular replacement air filter.
Gold Yeller is offline   Reply With Quote
Old 06-18-2010, 07:13 PM   #7
dfayette
Roverito
 
Join Date: Aug 2009
Posts: 8
I replaced the MAF sensor.
Cleaning did not work. K&N should be just fine since it does not interfere with the MAF.
dfayette is offline   Reply With Quote
Old 06-22-2010, 11:04 AM   #8
Gold Yeller
Roverito
 
Join Date: Jun 2010
Posts: 2
Thanks, it looks like I'll go that route myself as I replaced with a WIX paper filter and still did not resolve issue.
Gold Yeller is offline   Reply With Quote
Old 06-22-2010, 11:30 AM   #9
Disco Mike
Full Access Member
 
Disco Mike's Avatar
 
Join Date: Jun 2009
Posts: 1,882
Replace the MAF, since cleaning won't help that particular one, use only factory air filters and throw that K&N as far away as possible.
__________________
Mike

I am a retired service manager of 30 years, currently driving a 99 D2 with the following mods.
Custom made front and rear bumpers, Warn 9500 HSI with 3/8th's rope, sliders, QT diff. guards, electronic CDL, 4:11 gears, rear Detroit with HD axles, Front T.T., HID head light conversions and 3 extra bumper mounted HIDs.

To download the RAVE manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm
Disco Mike is offline   Reply With Quote
Old 07-28-2011, 08:19 PM   #10
RoverProblem
Roverito
 
Join Date: Jul 2011
Posts: 3
Question 2001 range rover codes


Register to remove these ads. It's free!
Disco mike

I have a 2001 range rover I read your reply for this thread and bought a mas air flow sensor from napa its not a Bosch brand is that okay? With this sensor I get code p1775 p1772 p0447 please help any one I spent way to much already trying to fix this car
RoverProblem is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off





All times are GMT -4. The time now is 02:59 PM.


Sponsor Ads





Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Land Rover and Range Rover Forums
Fully Driven Auto Network
GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Ford Raptor Forum
Scion FR-S Forum
Softball Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum