Go Back   Land Rover and Range Rover Forums > Technical Discussions > LR3

Sponsored Ads
Register or log in to remove these ads.

LR3 technical discussions for the LR3


Reply
 
Thread Tools
Old 01-31-2012, 02:31 PM   #1
er1c
Full Access Member
 
Join Date: Feb 2011
Posts: 52
Question Help: rear brake disc removal woes


Register to remove these ads. It's free!
So, I'm trying to remove my right-side, rear rotor from my LR3. But, unfortunately, I'm having no luck.

Once the wheel is removed, I then remove the caliper off of the brake disc. I've then removed the EPB tensioner plastic cover. From what I've read, I'm to then rotate the brake disc towards the front of the vehicle; this is to align the exposed hole (which I removed the cover from), with the EPB adjuster. Sadly, this is where I'm running into trouble. I can only rotate the disc forward about an inch, and then it won't budge a hair more. I've checked in the hole, and the tensioner is not visible in the 1-inch movement area at all.

My EPB is making a ton of noise, and I desperately need to swap out the shoes for new ones that I've picked up.

I took a short video to illustrate my problem. It's available for viewing at: http://youtu.be/4gug1VPLcSY

The weather outside today is unusually warm (52 degrees), and I desperately want to get this work done today. So, any insight would be greatly appreciated.
er1c is offline   Reply With Quote
Old 01-31-2012, 03:30 PM   #2
ryan-in-oregon
Full Access Member
 
ryan-in-oregon's Avatar
 
Join Date: Jul 2009
Posts: 538
Not to rain on your parade but do you have the Bodsy Brake Bible? It tells you how to put the epb into service mode and fully release tension. You do not need to remove the plastic line cover as it doesn't release any of the tension. You will also need to follow all the procedures on setting up and bedding in the new shoes. Your existing shoes are worn down likely because of an improper adjustment in the past. I would link you to the site for the brake bible but this forum will block it. Just google it. Good Luck!
__________________
Ryan - W7HUN
84 Defender 110 - 2" OME Lift, Mantec Tire Carrier, Full Length Roof rack,

05 V8SE 265/65R18 BFG AT, Sensor Mod, 28gallon Aux Fuel tank, Custom Fab rear bumper with wrap around protection and integrated swing-away tire carrier, Custom Rock Sliders, RAI, Toughbook mount w/cf-28, OnBoard Air -GONE
ryan-in-oregon is offline   Reply With Quote
Old 01-31-2012, 04:31 PM   #3
er1c
Full Access Member
 
Join Date: Feb 2011
Posts: 52
Ryan, of course I've read Body's brake bible.

And, the first thing I did was put the EPB into service mode before doing any work.

And you do, too, need to remove the "plastic cover" off of the rotor. Behind the plastic cover is how you access the EPB tension adjuster.

I also have printed the Land Rover procedure for bedding in the brake shoes. I'm well aware of all of that.

My problem---as is apparent in the video I uploaded to YouTube--- is that after removing the caliper from the disc, along with removing the T50 bolt, the rotor is refusing to come off. As per Bodsy's Brake Bible, it instructs you to relieve the tension via the toothed adjuster. Thus the need to remove the plastic cover, sticking a flat-head screwdriver into said hole and turning it.

My EPB is making a clanking/scraping sound as the wheel rotates. I took a rubber mallet and pounded the rotor in the areas where the parking shoes are located. That gets rid of the sound completely. When I go to apply the EPB again, the sound comes back. That's how I know it's the parking brake shoes.

My only issue right now is not being able to take the rotor off to access the parking brake shoes.
er1c is offline   Reply With Quote
Old 01-31-2012, 05:08 PM   #4
ryan-in-oregon
Full Access Member
 
ryan-in-oregon's Avatar
 
Join Date: Jul 2009
Posts: 538
To remove the disc you shouldn't need to remove the cover. The shoes are not supposed to drag on the disc. Likely what has happened is the shoes have ground a grove into the drum and are jamming against the lip on either side of the shoe. Or the cable is extended and jammed. Do you have a fault on the dash?

I have been there done that with the epb including replacing the entire module my self. Annual adjustments are necessary when it comes to the epb.
__________________
Ryan - W7HUN
84 Defender 110 - 2" OME Lift, Mantec Tire Carrier, Full Length Roof rack,

05 V8SE 265/65R18 BFG AT, Sensor Mod, 28gallon Aux Fuel tank, Custom Fab rear bumper with wrap around protection and integrated swing-away tire carrier, Custom Rock Sliders, RAI, Toughbook mount w/cf-28, OnBoard Air -GONE
ryan-in-oregon is offline   Reply With Quote
Old 01-31-2012, 05:46 PM   #5
er1c
Full Access Member
 
Join Date: Feb 2011
Posts: 52
No, sir. No fault code. That's what I was suspecting, too. Like you said, I'm thinking they might be jammed.

So, when replacing the parking brake shoes, I don't need to release the tension via the adjuster before taking the rotor disc off? You're saying that I only need to unbolt the T50 screw, and the rotor will come off? I tried doing that, and it won't budge. Any advice, Ryan?
er1c is offline   Reply With Quote
Old 01-31-2012, 08:26 PM   #6
ryan-in-oregon
Full Access Member
 
ryan-in-oregon's Avatar
 
Join Date: Jul 2009
Posts: 538
That is correct to simply remove the disc you shouldn't have to touch the adjuster. Once removed and if you replace the shoes you will need to set it back to the minimum setting to get the rotor to fit back on...Try rocking the rotor back and forth several times break it loose. Hopefully that will solve the problem. If not there is an "unjam" feature in the dealers diagnostic tool (my faultmate also has it) that should fully retract the cables. Good Luck...
__________________
Ryan - W7HUN
84 Defender 110 - 2" OME Lift, Mantec Tire Carrier, Full Length Roof rack,

05 V8SE 265/65R18 BFG AT, Sensor Mod, 28gallon Aux Fuel tank, Custom Fab rear bumper with wrap around protection and integrated swing-away tire carrier, Custom Rock Sliders, RAI, Toughbook mount w/cf-28, OnBoard Air -GONE
ryan-in-oregon is offline   Reply With Quote
Old 01-31-2012, 08:27 PM   #7
ryan-in-oregon
Full Access Member
 
ryan-in-oregon's Avatar
 
Join Date: Jul 2009
Posts: 538
Did you try beating around the hub with a rubber mallet to "shock" it loose?
__________________
Ryan - W7HUN
84 Defender 110 - 2" OME Lift, Mantec Tire Carrier, Full Length Roof rack,

05 V8SE 265/65R18 BFG AT, Sensor Mod, 28gallon Aux Fuel tank, Custom Fab rear bumper with wrap around protection and integrated swing-away tire carrier, Custom Rock Sliders, RAI, Toughbook mount w/cf-28, OnBoard Air -GONE
ryan-in-oregon is offline   Reply With Quote
Old 01-31-2012, 09:52 PM   #8
er1c
Full Access Member
 
Join Date: Feb 2011
Posts: 52
Ryan, I was out there for over an hour trying to get it off--- all to no avail.

I whacked, and whacked, and whacked some more against the rotor. It won't budge.

Fortunately, my left-side rear hasn't made any noise though. So, tomorrow I'm going to work on the opposite side. I have no reason to think that this side will give me any trouble.

Perhaps visually seeing up-close the internals of the left-side, will allow me to see where to focus my attention to for the jammed right side.

When I do get the right disc off though, I'll be sure to take pictures if anything is out of whack. So, hopefully it can be used to aid some other poor chap in the future, if he's in the same predicament as me.

Thanks for your help, Ryan. And, by-the-way, seeing your LR3's modifications at the end of 2010 was what ultimately persuaded me to buy my LR3.
er1c is offline   Reply With Quote
Old 02-01-2012, 02:07 AM   #9
Trynian
Full Access Member
 
Join Date: Aug 2008
Posts: 780
Do you have both wheels off the ground? If not, one side will not rotate unless the other side is off the ground.
__________________
2006 LR3
Trynian is offline   Reply With Quote
Old 02-01-2012, 06:09 AM   #10
e24kgold
Full Access Member
 
Join Date: Jan 2010
Posts: 319


Register to remove these ads. It's free!
I just did my rear brakes 2 days ago. Both wheels must be off the ground. My rotors were stubborn as well. Just hit it a little, rotate, hit again and it should come right off. Also you don't need to remove the plastic cover to adjust the epb.
e24kgold is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off





All times are GMT -4. The time now is 09:21 AM.


Sponsor Ads





Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Land Rover and Range Rover Forums
Fully Driven Auto Network
GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Ford Raptor Forum
Scion FR-S Forum
Softball Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum