Heater doesn't work om the driver side

Discussion in 'LR2' started by Josh Piazza, Oct 4, 2016.

  1. Josh Piazza

    Josh Piazza New Member

    Age:
    30
    Posts:
    3
    Likes Received:
    0
    Joined:
    Oct 4, 2016
    Location:
    59602
    My wife's 2008 LR2 will only blow cold air on the drivers side. The passenger side however, does blow hot air. From what I can tell it might be the blender doors in the vent. Does any one have any experience with this? where is the blender door located and how hard is it to change?
     
  2. Matt Poirier

    Matt Poirier New Member

    Age:
    43
    Posts:
    1
    Likes Received:
    0
    Joined:
    Oct 8, 2016
    Location:
    Flagstaff
    I have the exact same problem. I am ready to try to fix it if you have figured anything out.
     
  3. Josh Piazza

    Josh Piazza New Member

    Age:
    30
    Posts:
    3
    Likes Received:
    0
    Joined:
    Oct 4, 2016
    Location:
    59602
    I haven't made any progress on this issue. The closest dealer is 500 miles away and I haven't found anyone local that works on LR yet.
     
  4. Crosboro

    Crosboro New Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jul 5, 2015
    Mine does the same thing, but not long term. When it's blowing cold air, there's a repeating slight sound, sort of a metallic "woo-woo woo-woo". Eventually, it starts blowing warm air. This happens after I've used the AC. It would be nice to find a solution at a reasonable cost.
     

Share This Page