Proud 2005 LR3 Owner, crazy quirks and all.

Discussion in 'Introduction' started by Gopirates367, Dec 3, 2017.

  1. Gopirates367

    Gopirates367 New Member

    Age:
    47
    Posts:
    1
    Likes Received:
    1
    Joined:
    Dec 3, 2017
    Location:
    Morehead City, North Carolina
    Hi guys,

    I've owned a 2005 LR3 since '07 and love it, expensive repairs, quirks, and everything that goes along with it. I appreciate this site a great deal as I've found answers to numerous "issues" that have popped up on my LR3 over the years and finally decided to join and relay that appreciation. I recently started having the "transmission fault, HDC, brake" issue. I've read the threads related to it and will start with the simple troubleshooting items and hope one of them rectifies the problem. I will say that I recently had to have the parking brake system, I guess you'd call it, replaced and only after that did these faults begin showing up. I also replaced a brake light recently with an aftermarket bulb which I'll switch to an OEM LR bulb as well. Again, I do appreciate all of the knowledge and insight shared here. It really makes working on my LR a much less stressful and really an actually enjoyable experience.

    Just to add something I thought of after initial posting. At start up most of the time when driving before the engine is fully warmed the tac bounces a few hundred RPM and the engine hunts slightly. Anyone else every experienced this issue and if so how was it addressed? Thanks in advance.

    Thanks again,

    Wayne, AKA Gopirates367
     
    Last edited: Dec 3, 2017
    Chrisva likes this.
  2. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,607
    Likes Received:
    19
    Joined:
    Jun 28, 2004
    Welcome to the forum. Tech questions are best in the correct forum section... but it please provide mileage and any maintenance that has been done before or after the issue occurred.
     

Share This Page