Trailer light question

Discussion in 'LR4' started by Gmosley, Jul 11, 2016.

  1. Gmosley

    Gmosley Well-Known Member

    Posts:
    46
    Likes Received:
    1
    Joined:
    Jan 7, 2014
    I did some searches before writing this, so I apologize up front if this question has been asked. I hooked up my trailer wiring harness this weekend so I could pull a 19ft boat. Would have had the dealer do it, but they couldn't fit me in. I know I still have to go back for the programming. My brake lights and signals work fine, but the tail lights don't come on. The boat dealer said the lights all worked, although I never noticed since everything was done during the day hours. I checked the fuses and the ground and all are good. The trailer does have LED lights and I am wondering if this is the issue. I will hook it up to a friend's truck tonight to see if they work as designed, which should point to something in the LR4. If it is due to the LED tail/side lights, is there a simple solution? Thanks in advance for any help.
     
  2. Lgibson

    Lgibson Full Access Member

    Posts:
    222
    Likes Received:
    3
    Joined:
    Dec 25, 2014
    I did a thread on this here May '15. To summarize, our 2015 LR4 trailer control module needed to "see"14 watts load before it would come to life, turning off the parking sensors, indicating in the cluster etc. i put 10 ohm 20 watt resistors in line with the our trailer's LED's. Problem solved, at least for that trailer. There are plenty of LED adapters out there but most are 7 pin round to 4 or 5 straight. The only 7 to 7 I found was way too bulky.

    BTW, the IID TOOL is great for coding in your trailer.
     
  3. Gmosley

    Gmosley Well-Known Member

    Posts:
    46
    Likes Received:
    1
    Joined:
    Jan 7, 2014
    I appreciate the input, but at first glance it sounds like too much work for what I thought would be a simple plug and play effort. I tested the trailer on a friend's truck and it worked fine. I made a call about the LED lights and was told if that was the problem I would get rapid flashing of the lights. I decided to swap out fuse 27, but that didn't do anything. I rechecked all of the connection and they are tight. Everything works except the running lights which is one of the 5 active blades. I will test to see if there is power going to that blade tomorrow. If there is power then I guess I will have to try what you mentioned. Just to be clear though, did you also have everything else working except the running lights?
     
  4. Lgibson

    Lgibson Full Access Member

    Posts:
    222
    Likes Received:
    3
    Joined:
    Dec 25, 2014
    Don't really know what was working because the rear parking sensor was driving us crazy in reverse. We use the Tekonsha RF which has the round 7-pin output as well as input.
     
  5. mbw

    mbw Full Access Member

    Posts:
    1,424
    Likes Received:
    175
    Joined:
    Aug 8, 2010
    Location:
    Dubuque, IA
  6. Lgibson

    Lgibson Full Access Member

    Posts:
    222
    Likes Received:
    3
    Joined:
    Dec 25, 2014
    I looked at that Curt but didn't want it wagging around back there. Wish there were a compact version without the cable. IMO there is also an issue with the resistance being inadequate to trigger the LR electronics, as most of those adapters use 100 ohm resisters which only draw 1.4 watts. I had to go all the way to 10 ohms (14.4 watts) before the dash trailer icon lit.
     
    Last edited: Jul 13, 2016
  7. mbw

    mbw Full Access Member

    Posts:
    1,424
    Likes Received:
    175
    Joined:
    Aug 8, 2010
    Location:
    Dubuque, IA
    That seems like a low of draw. What resistors did you end up using? How/where did you add them in? I think I am going to have to do the same as you.
     
  8. jaamrode

    jaamrode Full Access Member

    Posts:
    71
    Likes Received:
    7
    Joined:
    Apr 15, 2014
    Did LR change the trailer sense signal from the brake/turn lights to the taillight when they went from the LR3 to the LR4. The LED lights however all work on the LR3 it's just that the brake lights pulse on and off if you don't put the resistor in. I had a problem of the contacts in the plug were not making a good connection and had to wiggle the plug a bit for the taillights to turn on. I ended up having to bend the contacts a bit so they would keep a good connection.
     
  9. Lgibson

    Lgibson Full Access Member

    Posts:
    222
    Likes Received:
    3
    Joined:
    Dec 25, 2014
    Not having a variable resistor for testing I purchased a complete selection of mini-bulbs and proceded to test them in order of draw at the LR4's trailer connector. Not until I reached the one drawing 14.4 watts did the trailer icon in the cluster light up. The charts show 12 volts at 10 ohms will use 14.4 watts. I bought three 10 ohm 20 watt resistors off Amazon or Ebay and inserted them in the LED leads under the trailer bumper, one for running lights and one for each side. For me with only one trailer this was a good solution.
    I have no idea about trailer control electronics of LR3 vs LR4. Perhaps check part numbers and software levels?
     
  10. Gmosley

    Gmosley Well-Known Member

    Posts:
    46
    Likes Received:
    1
    Joined:
    Jan 7, 2014
    After LR programmed the vehicle there still was no power to the tail lights. They checked the tow harness and it was good. They checked the vehicle and discovered that there was a wire missing. Evidently there was something LR sent out a year or two ago that some vehicles may be missing this wire. You would never know unless you planned on towing. So they ordered the required harness and should have everything ready tomorrow. They even said they will install the tow harness at no charge. I can't complain about that since they way they install it by removing the bumber might be more secure than how I installed it by just routing it under the back of the vehicle. I did get the chance to play around with the tow assist feature yesterday and I liked what the camera does. Thanks for the replies. Hopefully Saturday morning I am able to head to the lake in the early hours with lights on the boat trailer
     
    SKOGSLR3 likes this.

Share This Page