1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recent Activity

Activity stream for all registered members at Land Rover and Range Rover Forums.

  1. David DAgostino posted a new thread.

    LR4 Transmission Heat Shield is missing. Is it necessary?

    I have a 2011 LR4 (second owner) that is just at 100k and about to get the transmission serviced. I noticed the heat shield and frame...

    Forum: LR4

    Apr 6, 2020 at 3:49 PM
  2. Stuart Barnes Time for some bushings...... »

    Apr 6, 2020 at 2:59 PM
  3. AdventureTim replied to the thread Possible windshield prep?.

    Who's your insurer out of interest?

    Apr 6, 2020 at 2:57 PM
  4. bbyer replied to the thread Possible windshield prep?.

    I agree; usually they have a Pilkington in stock or within a week but last year, not so - it puzzled me as well. A few years back I had...

    Apr 6, 2020 at 2:56 PM
  5. bbyer liked f1racer328's post in the thread Possible windshield prep?.

    Seriously? I just had my dealer replace my windshield with an OEM one, insurance paid for it all. (AZ has no deductible on glass) They...

    Apr 6, 2020 at 2:53 PM
  6. f1racer328 replied to the thread Possible windshield prep?.

    Seriously? I just had my dealer replace my windshield with an OEM one, insurance paid for it all. (AZ has no deductible on glass) They...

    Apr 6, 2020 at 2:04 PM
  7. chakadog replied to the thread Would like to confirm a few details on 2015 SCV6 maintenance.

    This looks like the list I'm working up. Not quite twice your mileage, though!

    Apr 6, 2020 at 1:04 PM
  8. Red Top Engine replied to the thread LR4 whining noise turned into a loud clicking noise now.

    Possibilities: Serpentine bearings- Check each for excess play/movement. A worn belt- check for tears. A defective tensioner: observe...

    Apr 6, 2020 at 12:25 PM
  9. Red Top Engine replied to the thread LR4 SCV6 Engine noise (and Fan problems).

    My LR4 (with no supercharger) started making same ticking noise. It's not the pulley nor the water-pump as I've replaced all of those....

    Apr 6, 2020 at 12:17 PM
  10. Waterndirt replied to the thread 2014 LR4 Power Failure.

    How about disconnecting the battery for an hour? BTW, I have a 2015 and I'm on my 3rd battery. The vehicle itself will kill it...

    Apr 6, 2020 at 11:15 AM
  11. djkaosone liked James Joliat's post in the thread 2014 LR4 Power Failure.

    Thanks DJK. I'll try that out today, I appreciate the response. Let you know if any of it works.

    Apr 6, 2020 at 11:07 AM
  12. James Joliat replied to the thread 2014 LR4 Power Failure.

    Thanks DJK. I'll try that out today, I appreciate the response. Let you know if any of it works.

    Apr 6, 2020 at 11:02 AM
  13. djkaosone attached a file to the thread Done with mechanics/anyone know what this cylinder bank,cam cover bolt is called.

    I'm 100% sure that's the correct bolt in the correct spot. [ATTACH]

    20190204_204049-800x600.jpg Apr 6, 2020 at 11:01 AM
  14. djkaosone replied to the thread 2014 LR4 Power Failure.

    Looks like you've done what I would have done. The next thing I would do is to see if a code reader will bring up any codes, if it does...

    Apr 6, 2020 at 10:32 AM
  15. bbyer replied to the thread Defender(s) making a massive scene recovering a 20ton truck.

    I am not certain about fake, but I did wonder how two new Defenders that really do not yet exist show up in the same place. I presume...

    Apr 6, 2020 at 10:32 AM
Loading...