2010 LR4 - Scraping Noise When Turning

Discussion in 'LR4' started by Preetsarai, Oct 6, 2018.

  1. Preetsarai

    Preetsarai Member

    Posts:
    13
    Likes Received:
    5
    Joined:
    Jan 13, 2015
    Location:
    Jersey City, NJ
    My 2010 LR4 with 80k miles makes a nasty scraping noise when turning hard RIGHT and backing up. Doesn't happen while turning left or moving forward.

    See video to hear the sound ...



    Both front lower control arms were replaced recently.

    I took the vehicle to an independent LR specialist earlier. He applied grease at some specific points where the steering locks at full turn. That seemed to have sorted the issue for 3-4 weeks, but now the noise is back.

    Any clues where the noise is coming from?
     
  2. Preetsarai

    Preetsarai Member

    Posts:
    13
    Likes Received:
    5
    Joined:
    Jan 13, 2015
    Location:
    Jersey City, NJ
    So no one has experienced this issue? Any suggestions what might be the issue?
     
  3. ryanjl

    ryanjl Full Access Member

    Posts:
    791
    Likes Received:
    275
    Joined:
    Dec 31, 2015
    Location:
    KCMO
    Sounds like the dust shield for the brake rotors might be hitting something.
     
  4. ambrown31

    ambrown31 Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Apr 20, 2016
    I had an odd popping/grinding noise at full lock on my lr3. I replaced the fluid in my front diff and transfer case and it solved my problem. I suspect I had some binding somewhere. might be worth a try if you are due for a fluid change.
     
  5. Parker Freeland

    Parker Freeland Member

    Age:
    58
    Posts:
    19
    Likes Received:
    7
    Joined:
    Jun 28, 2018
    Location:
    Denver, CO
  6. Preetsarai

    Preetsarai Member

    Posts:
    13
    Likes Received:
    5
    Joined:
    Jan 13, 2015
    Location:
    Jersey City, NJ
  7. Krill

    Krill Member

    Age:
    22
    Posts:
    18
    Likes Received:
    9
    Joined:
    Oct 22, 2018
    Location:
    Wellington Florida
    E18D524E-B50D-4515-B098-30D0E45A699A.jpeg I had the EXACT same noise only would happen while backing out of my driveway. I brushed a little anti-seize on the 2 spots and haven’t had a issue ( it’s been probably 10,000 miles and quite a bit of mud sand and flooded roads) sorry for the crappy pictures. Hope this helps
     
  8. Preetsarai

    Preetsarai Member

    Posts:
    13
    Likes Received:
    5
    Joined:
    Jan 13, 2015
    Location:
    Jersey City, NJ
    Thanks! This is helpful. Can you circle the spots on the image where you applied the anti-freeze? It’s hard to tell where I need to apply it.
     
  9. Krill

    Krill Member

    Age:
    22
    Posts:
    18
    Likes Received:
    9
    Joined:
    Oct 22, 2018
    Location:
    Wellington Florida

    Yeah sorry here the pic. And the stuff I think lasts the longest is the silver paste, not the copper one

    D616D099-AAE0-4352-A100-68BAED6DEE4F.jpeg

    image.jpg
     
  10. Preetsarai

    Preetsarai Member

    Posts:
    13
    Likes Received:
    5
    Joined:
    Jan 13, 2015
    Location:
    Jersey City, NJ

Share This Page