2011 lr4 hd radio problem

Discussion in 'LR4' started by Blkrover1111, Oct 8, 2018.

  1. Blkrover1111

    Blkrover1111 Member

    Age:
    37
    Posts:
    12
    Likes Received:
    0
    Joined:
    Oct 5, 2018
    Location:
    North hollywood
    Hi guys I have a problem with the radio any help would be great the problem is that when I go on to the radio settings there is an option to turn the HD radio on and off mine is stuck on off when i press on it won't change i tried the following did a hard reset with the battery that did not work went in the control module with the iid tool and checked no faults and it shows that it is is equipped anyone knows what the problem hight be
     
  2. jaguardoc504

    jaguardoc504 Full Access Member

    Posts:
    376
    Likes Received:
    68
    Joined:
    Feb 10, 2014
    Possible you do not have the HD radio module fitted.
    I get incorrect fitted/not fitted errors on a few different modules when the CCF is pulled.
     
  3. Blkrover1111

    Blkrover1111 Member

    Age:
    37
    Posts:
    12
    Likes Received:
    0
    Joined:
    Oct 5, 2018
    Location:
    North hollywood
    It shows fitted
     
  4. ZR1Gerhardt

    ZR1Gerhardt Member

    Age:
    46
    Posts:
    14
    Likes Received:
    1
    Joined:
    Apr 23, 2016
    I had to use my IID tool to log into the computer and tell it that I had an HD radio. After that, it always worked. You might have to have LR log in and change it. They might charge and arm and a leg just to do that though!

    Scott
     

Share This Page