2011 Range Rover 5.0 HSE fuel rail pressure low code

Discussion in 'Range Rover' started by Joe DelVecchio, May 28, 2017.

  1. Joe DelVecchio

    Joe DelVecchio New Member

    Age:
    56
    Posts:
    2
    Likes Received:
    1
    Joined:
    May 28, 2017
    Location:
    Tucson AZ
    I have seen many posts online with this issue. Mine has the vehicle in Reduced performance mode. I have checked all components of the fuel system. Vehicle starts rough when cold but soon smooths out with no mis-fires. Drives fine, although limited power due to the fault. Fuel pressure at the rail is fine. Pump runs fine. No clogged injectors, MAFS's good. This all happened when I turned a corner, rpm's came down but it stayed in 3rd gear and bogged down. Transmission is ok. I wondered if the anyone knows about the software upgrade and if it addresses this issue. It seems the computer sometimes doesn't shift all the way down on turns or stops.
    2011 RR 5.0 HSE, non-supercharged, not a sport
     
    Jake Barrell likes this.
  2. canrover

    canrover Member

    Posts:
    22
    Likes Received:
    2
    Joined:
    Dec 16, 2015
    "Fuel pressure at the rail is fine. Pump runs fine. No clogged injectors, MAFS's good."

    How do you know all this? Did you actually run pressure tests? what code are you getting? Give us the exact code so we can help.
     
  3. Joe DelVecchio

    Joe DelVecchio New Member

    Age:
    56
    Posts:
    2
    Likes Received:
    1
    Joined:
    May 28, 2017
    Location:
    Tucson AZ
    I did test, MAF passed, Injectors are fine, engine runs smooth after codes are cleared. After restarting "reduced performance" comes on, after that when started it runs rough until the rpms come down to normal. Then engine runs fine again, no misfires, idles fine, just low power. From the fuel rail I get "Fuel rail pressure high range sensor 64.8 lbf(448 Kpa), Fuel rail pressure-Low range sensor 2.28 V, Fuel rail pressure-High range sensor .59 V, Fuel rail pressure 46 lbf (320 Kpa) so the pressure is low and sending that to the computer and thats keeping it in low performance mode. So I'm thinking fuel delivery module or fuel pump. Thanks

    Was getting P0087 low fuel rail pressure
     
  4. canrover

    canrover Member

    Posts:
    22
    Likes Received:
    2
    Joined:
    Dec 16, 2015
    Low fuel rail pressure may mean a bad High Pressure pump. This would be beyond my expertise and I would take that to a tech but yeah.. I'm thinking Bad HP pump and/or clogged fuel filter
     
  5. stl8grey

    stl8grey Full Access Member

    Age:
    43
    Posts:
    63
    Likes Received:
    17
    Joined:
    Feb 4, 2016
    What was the remedy? I have had a P0087 code that I am quite well invested into and LR4 still stalls.
     
  6. Bill Hunt

    Bill Hunt New Member

    Age:
    44
    Posts:
    1
    Likes Received:
    0
    Joined:
    Jul 10, 2019
    Location:
    canada
    any fix? I have the same issue
     
  7. stl8grey

    stl8grey Full Access Member

    Age:
    43
    Posts:
    63
    Likes Received:
    17
    Joined:
    Feb 4, 2016
    Mine fixed by replacing LR015356 sensor that is on the passenger side of the transmission.
     
  8. Adesoji

    Adesoji New Member

    Age:
    32
    Posts:
    1
    Likes Received:
    0
    Joined:
    Nov 5, 2019
    Location:
    Lagos Nigeria
    Hi, pls what’s the name of the unit changed
     
  9. stl8grey

    stl8grey Full Access Member

    Age:
    43
    Posts:
    63
    Likes Received:
    17
    Joined:
    Feb 4, 2016
    On some sites it is called a low pressure sensor. I got it directly from the dealer.
     

Share This Page