2012 Range Rover - AC/Heater Blower fan motor not working.

Mannyac

New Member
Joined
Nov 28, 2021
Posts
3
Reaction score
0
Location
98077
Checked Blower resistor impedances and it appears to be working fine and no damage, checked voltages at resistor connector and getting 7 Volts from input - seems low so I am thinking it's a fuse relay connector. The blower fuse is fine, and there doesn't seem to be any other fuse or relay related the front fan blower motor, per the owner's manual. Grrr... Does anyone have an idea what other fuses or relays could be causing this problem with the blower fan motor? Any ideas besides what in the useless manual and the fuse box legend? Appreciate the help!!
 

joey

Custom Rover Accessories
Staff member
Joined
Jun 28, 2004
Posts
10,393
Reaction score
156
It could also be the control head unit.
 

Mannyac

New Member
Joined
Nov 28, 2021
Posts
3
Reaction score
0
Location
98077
Thanks Joey - if by control head unit you mean all the control panel buttons, they all work fine. I can even hear the AC compressor kick on, and the rear seat fan blower works fine as well. This is simply the front fan that stopped working. There has to be another relay or fuse other than the 10amp fuse #62 behind the glove box. Appreciate other ideas. Thanks!
 

Mannyac

New Member
Joined
Nov 28, 2021
Posts
3
Reaction score
0
Location
98077
Appreciate any ideas. Hard to believe no one has run into this problem or knows if there is another hidden fuse to this 2012 Range Rover. I guess I will have to take to a dealer and get the typical Range Rover overpriced repair price.
 

Tony Haynes

New Member
Joined
Jul 1, 2019
Posts
1
Reaction score
0
Location
Uk
Hi, did you sort the issue? Mine is doing the same and I am wondering how you sorted
 

Latest posts

Members online

Forum statistics

Threads
35,250
Posts
207,074
Members
29,465
Latest member
nikkijenn
Top