2013 Carplay Success!!

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

iSheeZ

Active Member
Joined
Nov 14, 2021
Posts
36
Reaction score
22
Location
Estonia (EU)
Please check Exit menu. You can find About info and if it looks like this – well, you just spent lots money because installation is plug and play and take maybe 1 or 2 hours (depends of your disassembly skills). I reported some bugs to Sinosmart after installed this they send me few beta firmware and finally fix it this spring.

I believe because I see on your photo Map selecting. You can use right (MODE) handle to change hovering on the screen and select or control by right side Mode button.
 

Attachments

  • tempImageRLzVSY.png
    tempImageRLzVSY.png
    860.8 KB · Views: 13

iSheeZ

Active Member
Joined
Nov 14, 2021
Posts
36
Reaction score
22
Location
Estonia (EU)
Also, this is how box looks like
 

Attachments

  • nfaK3Y5MoSPQPTbM7aJPUdXlTK4-1920.jpg
    nfaK3Y5MoSPQPTbM7aJPUdXlTK4-1920.jpg
    113.6 KB · Views: 11

ttforcefed

Full Access Member
Joined
Dec 19, 2010
Posts
604
Reaction score
180
The shop i used put me in touch with naviks in Brooklyn for some support questions.
 

ttforcefed

Full Access Member
Joined
Dec 19, 2010
Posts
604
Reaction score
180
So you are saying naviks is just the distributor?
 

Attachments

  • IMG_8132.jpeg
    IMG_8132.jpeg
    102.2 KB · Views: 13

Griffin2013

New Member
Joined
Jul 30, 2023
Posts
2
Reaction score
4
Location
USA
I just installed this system myself, in my '13 RRS.

There are multiple units out there with different names (Sinosmart, IDCore, Carsight, XCarlink etc.- mine is called "Road Top"), but they are all just clones of each other made in China running variations of the same software.

I bought mine on eBay for about $270. It took me about 3 hours to install and required some minor dash disassembly and removal of the infotainment screen. The instructions were appalling and often inaccurate (perhaps they pertain to one of the other variations!) and it took quite a bit of trial and error to get it working. But once it's done, it's excellent. Apple CarPlay runs smoothly, my rearview camera still works correctly, and I can switch back to the LR system at the touch of a button.
 

mm3846

Full Access Member
Joined
Feb 11, 2021
Posts
380
Reaction score
182
Location
LI, NY
Mine has a noticeable loss in volume (**** preamp I imagine) and the phone calls are very low. It’s an early IDCore.

Otherwise it’s perfect and I can’t live without it.
 

ttforcefed

Full Access Member
Joined
Dec 19, 2010
Posts
604
Reaction score
180
Mine has a noticeable loss in volume (**** preamp I imagine) and the phone calls are very low. It’s an early IDCore.

Otherwise it’s perfect and I can’t live without it.
Do guy have it setup through auxiliary or Bluetooth? I had those issues with auxiliary but not with Bluetooth
 

Latest posts

Members online

Forum statistics

Threads
36,324
Posts
218,735
Members
30,526
Latest member
casey1210
Top