2013 LR4 Transmission Gremlin

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Jan 1, 2021
Reaction score
Toronto, Canada
Help! Persistent slipping 1st to 2nd. Local indie workshop adjusted the gear lever cable and all well for a few weeks. Slipping came back, gearbox oil changed, new ZF 6HP28 Mechatronic Unit, new oil pan etc. Had to go to a JLR dealer for re-programming, ended up on-line to Solihull where factory took a full day to get the transmission to work. Amazingly JLR picked up all but one hour labour and the diagnostic fee. Again, all good for a several more weeks then back to more gear slipping. Back to the indie who was not able to locate the fault. Went to the JLR dealer, who reported low gearbox oil but no trace of a leak. Oil topped up and took the LR4 for a 250 mile round trip during which it ran like a Singer sewing machine. Went to move the car this afternoon, reversed fine but when I went to reverse a second time would not engage. On the dash the gear selection indicator now shows P-N-N-D, i.e two neutrals and no reverse. Connected my GAP tool, nothing happened, no light and no signal. Connected it to the IID updater, no apparent problems. Tried again in my car, but still dead. The indie workshop said they had taken a good look at the gearbox and it appeared to be in great shape, no metal filings in the oil which was still very clean. My gut tells me that the problem is in the electronics as another continuing mystery is a "low fob key battery" warning even though both batteries are new. Perhaps there is an old key fob lost in the car somewhere, but the vehicle remains locked provided the keys are not close by, so the problem is the message, to pun Marshall McLuhan. The trouble with most auto repairers these days is that they cannot identify the source of problems if their diagnostic tools do not give them the answer. So now I seem to be facing a full transmission tear-down and rebuild, which at 86,000 miles cannot be right.

Any suggestions?


Full Access Member
Mar 19, 2019
Reaction score
Northern California
I don’t see why anyone would suggesting a transmission tear down for this. Seems like it would need to be somewhere between the software control and the mechatronic unit. With that strange dash display, I’d be thinking a software/programming problem.

With regard to no power to the gap tool (key on), check your fuses first. There should be a fuse for the diagnostic port. In fact, while you’re in there, might check any fuses for your transmission control also, just in case.

If the fuse for the diagnostic port is okay, you can probe it with a multimeter to see if you have DC voltage. Not sure what pin port it would be, but you can put one probe on a good ground and just probe each port until you see voltage. If no volts, need to track that problem down first.

If you have voltage at the diagnostic port, but still no power to the gap tool, then its probably a loose pin receptacle. Each pin receptacle has a little hole next to it. You can shove a paperclip or something in there, which will tend to bend the contact pins back together and make tighter contact to the tool pins.

Latest posts

Forum statistics

Latest member