95 Disco wont start

Discussion in 'Discovery' started by Candace, Apr 16, 2017.

  1. Candace

    Candace New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Apr 16, 2017
    Location:
    hermiston, oregon
    OK I am new to this forum. I just got give my 95 Disco 1 3.9L V8 by my cousin. Was told that only the starter needed replaced (which it definitely did, it was BROKE). It didn't come with a battery either. I bought a BRAND NEW battery from work and a REMAN starter. All connected up, correctly. All fuses are good! All relays are good! When I turn the key nothing happens. There is no crank, there is no start, AT ALL! Everything is plugged in as it should. When I turn the key I can hear, and physically feel the starter relay trying to work. However, the fuel pump DOES NOT engage, there is no signs of cranking, and there is no signs of starter engaging. The flashers were flickering, so from reading on the forum I left the key in the one position and hit the inertira switch and waiting 5 minutes and the flashers did NOT turn off, and the Disco still would not crank or start. So then I took the key out (NO I DO NOT HAVE A CHIPPED KEY OR A FOB) shut the door and locked/unlocked the doors 5 times in a row. This disabled the flashers, but I still have a no crank no start and I am honestly out of ideas on what can be going on here. ALL THE LIGHTS WORK, the stereo DOES NOT work, the fans DO NOT work (which the fans and stereo are the least of my worries right now). ALL THE WINDOWS ROLL UP AND DOWN. THE WIPERS WORK. I am trying to get this baby on the road. PLEASE HELP ME I AM OUT OF IDEAS!!!

    Thanks!
     
  2. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,766
    Likes Received:
    51
    Joined:
    Jun 28, 2004
    Sounds like a security issue. I don't remember what year the dreaded rover Spider security was, hoping not your issue.

    When you put the key in and turn to start is the light still flashing on the dash? If so the alarm is still armed.
     
  3. Candace

    Candace New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Apr 16, 2017
    Location:
    hermiston, oregon

    When I put the key in and turn to start the light is NOT flashing on the dash. I was given nothing but a metal key, no fob and no chipped key for this thing. It has a new starter in it and I don't have a battery so I keep hooking a jumper to it. There is power getting to the starter, lights work, horn works, alarm works, wipers work, stereo works, speakers work, all windows work, all buttons work, but it will not try to crank and it will not try to turn over. I turn the key and there is absolutely nothing. Went to the diagnostics LED box, had code 02, cleared that, then had code 50 which is a misfire bank 2??? Cleared it and no more codes came on, tried to start it nothing, when I turn it to II on the ignition, nothing sounds like it is engaging though, the starter doesn't sound like it is engaging, the fuel pump doesn't sound like it is engaging. ALL FUSES are good, and ALL RELAYS are good, I checked them all with a multimeter and everything checks out to 12.6V. I am at a complete loss with this thing, I have been trying everything for months now it seems like and I really just want to scrap it, which ill only get like 100.00 out of it that way, but I know it will run and start. It was running a year ago, before the starter went out and it was parked. Any suggestions?
     
  4. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,766
    Likes Received:
    51
    Joined:
    Jun 28, 2004
    Put a battery in it. the jumper may not be enough.
     
  5. BronkoZ

    BronkoZ Member

    Age:
    26
    Posts:
    20
    Likes Received:
    2
    Joined:
    Jun 6, 2017
    Location:
    US, CA
    Hey, I had similar problem long time ago tho. Did you check your potentiometer?
     
  6. ndrsn_lr

    ndrsn_lr New Member

    Age:
    32
    Posts:
    1
    Likes Received:
    0
    Joined:
    Aug 12, 2018
    Location:
    ALABAMA
    Did you ever get this issue resolved?
     

Share This Page