Coolant Low level alarm but level normal

Anthony Sauer

New Member
Joined
Apr 28, 2017
Posts
3
Reaction score
0
Location
Somerset
2012 LR4 V6 Diesel Low level coolant alarm would initiate especially after hard acceleration. Now the alarm will come up after normal running and no hard acceleration. The level in the expansion tank is normal on all occasions. The coolant shows no signs of contamination. There is no evidence of air bubbles within the coolant. Alarm goes away and then later may, or may not come back on.

Help please
 

BigZ

Member
Joined
Aug 16, 2020
Posts
12
Reaction score
5
Location
Salt Lake City, UT USA
Look at the float in the expansion tank. If it’s stuck or broken then it’s the tank. I just changed my expansion tank as the float was in pieces. The new tank didn’t come with a sensor but I installed and used the old sensor. Works perfect.
 

ktm525

Full Access Member
Joined
Mar 26, 2017
Posts
2,054
Reaction score
917
Location
alberta
?? The sensors I have replaced come with a new float. I guess when I am saying sensor it is likely a dodgy float.

Capture1.PNG
 

99d2td5

Member
Joined
Nov 19, 2011
Posts
16
Reaction score
13
I had the same problem and did the same things - reluctantly changed the tank and all fixed.
 

bbyer

Full Access Member
Joined
Aug 15, 2008
Posts
886
Reaction score
147
Location
Alberta
?? The sensors I have replaced come with a new float. I guess when I am saying sensor it is likely a dodgy float.

View attachment 11721
The float is inside the tank if I understand correctly.

If so, I am to conclude you were able to also get at and remove the old float? If so, were you able to do all that with the tank still connected?

I ask as I am planning to replace the tank on my LR3 due to the heavy float reality. I just assumed a bad float meant install a new tank.
 

Latest posts

Members online

Forum statistics

Threads
35,241
Posts
206,989
Members
29,453
Latest member
rhweaver47
Top