Help DiscoII steering wheel controls dead, no horn and radio frozen

Discussion in 'Discovery' started by networka, Nov 11, 2018.

  1. networka

    networka Member

    Age:
    29
    Posts:
    7
    Likes Received:
    0
    Joined:
    Feb 7, 2015
    Hi guys,

    so a couple of weeks ago was raining hard and i have some "leaks" so it was also pouring inside. at some point i used the horn and it keep sounding non responsive to the button then it suddenly stop and didn't worked again, i imagined it was water in the steering wheel button and probably ended up blowing the fuse.

    but ever since then the radio is also frozen (original stock radio), the steering wheel controls are also dead... and i do hear a "tick" noise from the dashboard when i press the radio buttons or the steering wheel control buttons.

    also i disconnected the battery and when i reconnected it the radio worked for one single command after that it froze up again.

    i suspect something shorting because there was one day where it kind of fixed itself for a brief moment, radio worked fine so i happily turned the volume up... havent been able to have conversations inside anymore... which hasnt turn out to be a problem lol.

    im a noob with the discoII so please help... is this a fuse problem? if so which one should i be looking into? is this going to happen everytime my steering wheel gets wet?
     
  2. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,792
    Likes Received:
    54
    Joined:
    Jun 28, 2004
    Where was the water leaking at? And what all did you see get wet?
     
  3. networka

    networka Member

    Age:
    29
    Posts:
    7
    Likes Received:
    0
    Joined:
    Feb 7, 2015
    Hi Joey,

    the water comes from the upper left corner of the roof and leaks down thru the left pillar and the center of the roof rack down to the console.
    that day it got the steering wheel wet.
     
  4. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,792
    Likes Received:
    54
    Joined:
    Jun 28, 2004
    Sounds like the sunroof drains are clogged, sadly this could be a major repair. You have lots of electrical items in both areas that can cause all kinds of issues.
     

Share This Page