Help we have an electrical problem

kalani0115

New Member
Joined
Apr 20, 2022
Posts
1
Reaction score
0
Location
colorado
We have a 2007 LR3 that we put a the wolfbox mirror back up camera on. Since we put that in we have noticed that the front seat, vanity mirrors, and light in glove compartment will not work until the middle lights button is pushed on the back and front seat. When those are pushed they all have power and will work again it is very strange. There are no fuses blown and the seat relay and box are fine. We took the headline down to make sure there were no wires exposed and did not find anything with the wires exposed or touching anything because we were fishing wires through the headliner. We also uncooked everything from the rear camera and still not working. I don't know what it could be. There are no codes on the gap tool.
 

bbyer

Full Access Member
Joined
Aug 15, 2008
Posts
891
Reaction score
149
Location
Alberta
I am not really familiar with whatever the Wolfbox is. I see per their website there are a number of models, hence which model did you install?


Am I to assume the Wolfbox connects to some power source within the headliner - presumably something to do with the courtesy lights?

Did whatever you installed result in the removal of the existing rear view mirror? If so, I can see that creating a real fuss with the car computer.

I am not clear what you mean when you say "the middle lights button on the back and front seat."
 

Latest posts

Forum statistics

Threads
35,324
Posts
207,700
Members
29,582
Latest member
just4sweep
Top