Intermittent Suspension Fault

M32H32IS

Member
Joined
Feb 8, 2022
Posts
14
Reaction score
1
Location
Texas
Sometimes diagnostics aren’t necessary to troubleshoot.

Following advice here on the forum I removed the compressor cover and could hear leaking air from one of the brass fittings in the manifold assembly.

I removed all of the fittings & used silicon tape to cover the threads. Tightened everything back up and cycled the suspension. No leaks. No codes.

Thankfully it was something silly.
 

txfromwi

Full Access Member
Joined
Dec 18, 2013
Posts
221
Reaction score
62
Location
2013 in Houston and the 2016 in Rochester NY
MOST INTERESTING !!

Requesting your expertise...

The 2016 is now at home for summer maintenance....

IIDTool tells me that the air compressor is a Hitachi - hmmm.. (I was expecting it to say AMK...)

I do believe that I can read, and the compressor most clearly says AMK - hmmm..

So let's take a look at the relay...
I cannot locate any useful information in either the shop manual or the wiring diagrams.
Anyone know what the two different relays should be saying on the cases?
The photo of the relay is attached, it's the top right most relay in the photo.


Either the IID Tool is incorrect or we are running the wrong software - hmmm..

Once I determine if I have the correct relay, I suppose I re-flash the software ??

IMG_1634.jpg
 

M32H32IS

Member
Joined
Feb 8, 2022
Posts
14
Reaction score
1
Location
Texas
I highly suggest starting a new thread. I don’t know much about relays.

Seems to me that if your compressor says amk the iid tool should read amk. But, I’m not an expert like some folks here.
 

txfromwi

Full Access Member
Joined
Dec 18, 2013
Posts
221
Reaction score
62
Location
2013 in Houston and the 2016 in Rochester NY
As nearly as I can determine from various Rover and parts websites, the relay is correct.

SO, I reflashed the system and set the compressor to AMK.
So now the firmware matches the hardware.

It's been 2 days (so it has had some time to think about it) and a few trips and no error messages so far...

Fingers crossed...
 

Latest posts

Forum statistics

Threads
35,237
Posts
206,949
Members
29,443
Latest member
Ginna104
Top