LR4 air suspension stays up!

landylandy

Member
Joined
Jul 13, 2022
Posts
18
Reaction score
2
Location
california USA
Hi folks, on my 2012 LR4 now the air suspension goes up into off-road height and stays up there! When I press the button to lower the car it will stay down for a little while and then pump back up. No sagging over night, the compressor discharges after the pumping cycle (no exhaust valve issue) and there are NO codes I can read in the fancy scanning tool from my friend! Anyone any idea what this could be?
Oh yes, I checked all the level sensors and disconnected the plugs, blew them out and cleaned them before reconnecting! thanks for helping, Mitch
 

ryanjl

Full Access Member
Joined
Dec 31, 2015
Posts
2,684
Reaction score
1,536
Location
KCMO
Describe the "fancy scanning tool." A lot of scanning tools don't read the suspension faults on Land Rovers.

Is it going into what's referred to as "super off road" height, or just regular off road height? If it's the former, something is convincing your Rover that it's high centered. If it's the latter, who knows.

You could just have a faulty sensor. What does the "off road" screen look like on your dash? Anything wonky there?
 

landylandy

Member
Joined
Jul 13, 2022
Posts
18
Reaction score
2
Location
california USA
well the tool is "auto land scientech - iScan IIwt"
the preset is set to road mode, but it's stands are like I would raise it up with the manual adjustment button next to the preset rotating selector. If I push it into down mode, after driving shortly it will raise back up and give me the "slow down" warning in the dash.
I could read quite some data like all 4 corners height and all the level sensor seam to work just fine......
 

f1racer328

Full Access Member
Joined
Apr 18, 2017
Posts
479
Reaction score
213
Location
AZ
You could probably disconnect the height selector switch and see if it still changes, as a very basic diagnostic step. No idea if that inhibits anything though, and the switch is probably a pain to get to.
 

landylandy

Member
Joined
Jul 13, 2022
Posts
18
Reaction score
2
Location
california USA
That is probably not such a good idea. The system will not know when to shut off and keep pumping air into the bags until they burst (that much I know about air rides from my restorations on classic cars and Custom's)
The sensor are all looking good in the diagnostic tool data and I cleaned out all the contact to make sure there was no malfunction. I can only think of a command error in the system but it does not through any codes (at least not yet) so its a ***** to know whats going on....
Obviosely I am among the first ones to have that problem since its been very quite around my post here I guess... Normally you have no air instead of too much air I'm afraid, thanks!
 

djkaosone

'11 LR4 HSE LUX 5.0L V8
Joined
Oct 26, 2015
Posts
757
Reaction score
474
Location
SoCal
Do you have lift rods? It might think that it's "too low" and out of range of your height sensors, which would try to lift it back up. Best bet is to recalibrate your suspension with oem rods, whether you have lift rods or not.
 

ryanjl

Full Access Member
Joined
Dec 31, 2015
Posts
2,684
Reaction score
1,536
Location
KCMO
Did you look at the 4x4 screen on your stereo?

What happens if you drive over 25 mph?

Maybe just try disconnecting the battery for 20 seconds for a reboot.
 

landylandy

Member
Joined
Jul 13, 2022
Posts
18
Reaction score
2
Location
california USA
right, not looked at the 4x4 screen. did clear all codes a week ago after servicing the landy in its full, will checks green and report back!
 

landylandy

Member
Joined
Jul 13, 2022
Posts
18
Reaction score
2
Location
california USA
ok, so access mode is front 16" back 17", Rock Crawl is front 20" rear 21"
if I have it in street mode it goes up to 18" and 19" when driving 25mph or more but then does not go back down! when I switched back from Rock Crawl to street and disangage the transfer lock, it will not go down, stays up high!, I then have to manually make it deflate the air bags and it will go into access mode, then come back up to 18" -19" when driving! is that what it is supposed to do?
 

Latest posts

Members online

Forum statistics

Threads
35,458
Posts
208,826
Members
29,737
Latest member
AammYars
Top