numerous codes after lower control arms installed

jim andrews

Member
Joined
Nov 20, 2018
Posts
12
Reaction score
5
Location
canada
i have a 2012 lr4 5.0 v8 with approximately 189k km. the car has been great no electrical issues before. the electrical gremlins struck after some work i had done on the front end. specifically i had the lower control arms replaced on both sides of the truck. due to my distance from a lr dealer, i had to use a local mechanic to do the work. once the job was complete, i drove it home about 10 kms when the dash lights started to go on. hdc inoperable, stability control disengaged, suspension fault. and a few others.
i turned around and brought back and left him the truck for the next day. i received a call the next day saying it was cleared up and she should be good to go. i drove it home again and the same codes came back.

i have looked briefly at the truck to see if there are any obvious disconnections etc. which i could not find. i tested the battery thinking that he may have not when he did the work, but it was still showing 12.38 volts. the car will reset itself when you turn it off and will go about another 10kms before it goes through the same process again.

the car will drop down to the bump stops when the codes appear as well and the height adjustment light goes out. turn the car off and then it will go to normal drive height. if i turn it off before the code appears, the suspension will stay at the proper height.

i am looking for advice about what could be going on before i need to load the truck on a flatbed and travel close to 7 hours to have this problem solved at the closest lr dealership. any tips or answers would be much appreciated.
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
260
Reaction score
84
Location
Portland, OR, USA
Did they replace only the lower arms, or was there any work done on the upper arms? The height sensors connect via rods to the upper control arm. It's probably worth making sure that linkage is still connected to the control arm and height sensor. Also check that the electrical connector is in place and wires intact. Here my driver's side
PXL_20220925_005711425.jpg

The arm is pointing towards the rear.

Here's my passenger side, arm also pointing towards the rear:
PXL_20220925_010153457.jpg
 

jim andrews

Member
Joined
Nov 20, 2018
Posts
12
Reaction score
5
Location
canada
i was wondering why the truck will work right after. car comes up evenly and will hold the height as long as the code doesn't appear. if it came up crooked or sagging in one corner i would understand the idea that the rod height adjusters mite be damaged or unplugged.
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
260
Reaction score
84
Location
Portland, OR, USA
If a cable is damaged, or a plug not firmly seated, you could get 'noise' in the signal, including values that are out of range, that you only get when you are moving and have vibrations from the road. These implausible values could trigger the fault. I'd guess your driver's side cable got damaged, as (at least on mine) it's fairly exposed.
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
260
Reaction score
84
Location
Portland, OR, USA
If you can get someone to scan codes for you with an IID Tool or similar, it should tell you what is upsetting the system and narrow down your hunt. I don't know if generic scanners would show you all the info, or if you'd need a Land Rover specific tool.
 

sonicpix

Well-Known Member
Joined
Jun 29, 2017
Posts
47
Reaction score
9
Location
Ontario, Canada
I'm having the same issue. local reputable mechanic replaced my upper control arms and the truck sits on the bump stops. Compressor runs then shuts off right away. I suspected a leak, but, there are a couple things this thread has suggested, More than likely an alignment? He suggested an alignment but i was waiting until I replaced the front bearings. I asked in another thread about an alignmens but never got a replay. But the height sensors could be another. thanks.
 

Members online

Forum statistics

Threads
35,557
Posts
209,744
Members
29,809
Latest member
macdven
Top