OBD2 - How is this happening?

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.


New Member
Mar 2, 2023
Reaction score
NE Indiana
Hi all, first post.

been a Def4/LR4 owner for…4 days. 2010, HSE, 173k on the clock. Prior owner gave me a literal FOLIO of receipts.

it came with two issues, air suspension compressor dying and a lack of TPMS.

So, planning ahead, I purchased the Gap IID Tool in order to get ahead of the curve.

Off the bat, I have been beset with issues. The first time plugging it in, no connection. My phone is literally taped to the tool at this point, and the are learning each other intimately (you catch my drift?). I elect to try it with the vehicle turned on and suddenly all hell breaks loose.

Suddenly I have errors galore; Stability Control, Parking Brake, Engine codes…the. I noticed the gas gauge suddenly dropping, revs dropping and then the screens went blank.

After I turned it off, I put the battery tender back on and let it charge for a bit. I luckily had another reader for another vehicle, and tried it out and it ran. A little sluggish but I ran and gave me the reports and I was able to clear the engine codes. I did notice there was a slight hiccup when I plugged it in.

I thought to try running the Gap unit with a power brick attached and boom it connects. I’m able to get it at least registered, but it does not compete tasks. I noticed that every so once in a while, the voltage doesn’t list anymore, and it will get hung up on tasks.

So, back to the drawing board. I pulled the fuse and it looks fine, and checked out the OFB2 and only noticed a small pin bent.

Any other ideas on what could be the cause?

The battery is a Feb 2022 so that should hopefully not be part of the problem.


  • 00fb16c5_187a_4d02_8618_e886f36c43c2_bfec1d52b435d7453d7b8fe9216aba96d3e88b18.jpeg
    133.9 KB · Views: 27
  • b21eb3d9_040f_401a_bc82_20b6982f697d_38b85eb081e56ad45497c0062a990b80c2710dd9.jpeg
    61.8 KB · Views: 26
  • bb9b00cb_50cd_4129_9444_eeab2973c06e_2728cb51b0a994df6e85d3c5716d24ecee9f08f6.jpeg
    190.7 KB · Views: 25
  • cf69bc42_8d4f_4288_87c1_ed9a0549b1f2_b3c5ae35bed1e936720a143b6cc94c34c616c083.jpeg
    69.6 KB · Views: 29


Full Access Member
Mar 19, 2019
Reaction score
Northern California
I think the first thing to try is tightening up those OBD port receptacle slots. A couple of them look to have pretty wide gaps. Looks like a couple might have been removed in the past (looks like some gouging in the plastic around the pin slot). Loose contacts will definitely make the GAP tool freeze up.

You can test the contact gap by inserting something like a sewing needle (or some other pin with a similar width as the obd scanner pins) and see how well it grabs - should hold in the slot securely. If not, you need to tighten it up. You’ll see there is a movable little piece of plastic on each pin slot towards the center of the receptacle. If you push those laterally towards the pin slot, it will tend to bend the contacts together. Sometimes that works, sometimes it doesn’t, in which case you need to actually remove the male pin slot from the receptacle and bend it more forcefully.

Might also locate the pinout diagram for the OBD on this car and make sure the OBD pins look correct, since it appears someone might have been tampering with it.

Not sure why the car went nuts when you plugged in the scanner. Even with the above problems, I was not aware that this could happen. I’d check that battery with a multimeter. Pop the hood and let the car set for a good 10 minutes. Then test the voltage - you should see about 12.6. Lower is weak. 12v is very, very low. Below 12v is basically dead as far as these cars go. If it looks okay, put the multimeter in scan mode (max/min), hook it up with aligator clips and try starting the car. Then check the min voltage recorded. Should be about 9V or higher. Any lower, the battery is probably shot. Then check alternator - multimeter in normal mode, engine running, you should see something in the range of 14v, though it can vary some.

Finally, the GAP tool can fail. I just replaced mine (I was very disappointed in the longevity of the first one - only lasted a couple years).


Full Access Member
Dec 31, 2015
Reaction score
To add to what @jlglr4 said, I'd also contact GAP Diagnostic and see what they say. Could be a defective tool.


Full Access Member
Apr 14, 2021
Reaction score
Napa Valley
I thought to try running the Gap unit with a power brick attached and boom it connects. I’m able to get it at least registered, but it does not compete tasks. I noticed that every so once in a while, the voltage doesn’t list anymore, and it will get hung up on tasks.
Curious what this means? You're not having something attached to the usb port on the tool while it's plugged into the OBD are you? I don't think that's how that works. You also should ONLY use the cable that came with the GAP tool for computer setup, registration etc. Now, you didn't mention it, but you've followed all the instructions for setting up the tool right? Received the code from GAP etc? Sorry just making sure all procedures have been followed. Like others have said, make sure the batter is fully charged and make sure the tool is firmly seated in the OBD port. Assuming none of this corrects the situation, call GAP. I've had several tools and never had this issue. Good LUCK

Latest posts

Forum statistics

Latest member