Pending codes on a 110k mile 2011 LR4

jlach993

Full Access Member
Joined
Mar 13, 2013
Posts
470
Reaction score
178
Location
Fresh Meadows Queens NY
Hey everyone,

I’ve been battling a few pending codes for the past couple weeks. The engine light has never been triggered, but i sensed an issue when i noticed the truck stumbling a bit when it was idling at a stoplight. That made me check for codes with the scanner. It does NOT currently stumble and all is well by the way. Anyways it seems the codes are somewhat oxygen sensor related? I got one for bank 2 sensor 1 and another for bank 2 sensor 2? I’m guessing its one out of the two that’s failed and causing the other to throw a code as well. Can anyone confirm if they’ve ever had these codes together? Also i’ve cleared all of them but after a few days of driving the P003E comes on first, followed by the rest the next day or so. The random misfire code has me baffled as well….i may need new coils and plugs maybe? Please advice. Thanks!!

P003E - A Camshaft Profile Control Performance/Stuck Off (Bank 2)

P0060 - HO2S Heater Resistance (Bank 2, Sensor 2)

P0153 - 02 Sensor Circuit Slow Response (Bank 2, Sensor 1)

P0300 - Random Misfire Detected

P2300 - Ignition Coil A Primary Control Circuit Low
 

Attachments

  • F36C9CD7-0CBD-4850-94A6-9AD4E11F2E79.jpeg
    F36C9CD7-0CBD-4850-94A6-9AD4E11F2E79.jpeg
    141 KB · Views: 17

Members online

Forum statistics

Threads
35,399
Posts
208,336
Members
29,700
Latest member
Czeczenski
Top