Possible Electrical Issue

Discussion in 'LR3' started by Kris Romito, Jun 13, 2019.

  1. Kris Romito

    Kris Romito New Member

    Age:
    43
    Posts:
    2
    Likes Received:
    0
    Joined:
    Jun 13, 2019
    Location:
    North Carolina
    Hey guys! I purchased a 2007 LR3 and the vehicle has been running great.
    I have noticed recently that the interior light and dash lights seem to dim (not a full flicker)
    occasionally. I thought it might be a bulb getting ready to go bad but I don't think that is it.
    Also, another weird thing that has happened (that may be related) is my ac. I can hear it
    running when I turn it on but it seems like the heater blower is not working because no air
    is blowing out of vent. So I ordered a new heater blower two days ago, (haven't gotten it yet)
    and I drive it today and the ac is now blowing great. Has anyone else experienced anything like
    this? Thanks in advance for all of your help!
     
  2. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,575
    Likes Received:
    137
    Joined:
    Jan 6, 2006
    How healthy is your battery?
     
  3. Kris Romito

    Kris Romito New Member

    Age:
    43
    Posts:
    2
    Likes Received:
    0
    Joined:
    Jun 13, 2019
    Location:
    North Carolina
    Battery seems to be great. Also, noticed something new today. The air that comes out of the passenger side vents seems to be a bit warmer than the drivers side vents.
     
  4. catman

    catman Full Access Member

    Posts:
    564
    Likes Received:
    116
    Joined:
    May 4, 2015
    Location:
    The Relay Shack, Parts Unknown USA
    My AC was working fine during normal temps, but started blowing warmer air whenerver temps hit some threshold (I don't recall exactly what temp ° that was). It was also blowing slightly warmer air on the passenger side than the driver side and in the end it was just low on refrigerant. Once it was topped up back to spec it blew equally cool air again and both sides colder than before.

    You should also check your alternator - they cause a lot of funky electrical things when they start to fail.
     
  5. Ian Morrison

    Ian Morrison Active Member

    Age:
    58
    Posts:
    44
    Likes Received:
    13
    Joined:
    Apr 2, 2018
    Location:
    Birmingham
    Hi The lights problem could be a bad connection / bad earth fault.Try looking at the wiring connectors to your central fuse box. Also the battery saver relay ( q) again on your central fuse box could have a problem. I’ve had in the past relays which are controlling different circuits of the car which burn out on the one circuit and remain good on the other. The Battery saver relay controls most of your interior lights.
     
  6. remember5

    remember5 Full Access Member

    Posts:
    116
    Likes Received:
    25
    Joined:
    Nov 26, 2014
    I would hold up on the blower motor and do the freon charge. Keep in mind also there are 3 stepper motors that move the air vents around to direct the flow of air from floor to defrost and blended in between. I had the issue and replaced both motors on the right side and that cleared the issue from left to right but I have not replaced the one on the driver side which evidently controls the flaps for vertical blending, again from floor to defrost. That's on my list to do. Again I agree, charge the freon and also double check the batter and alternator output.

    On another note, does anyone have a link or access to the 2006 LR3 complete shop manual? I've had a catastrophic hard drive failure and have lost all my automotive related manuals and .pdfs. Thanks in advance.
     

Share This Page