Pressure doesn’t decrease when venting gallery

MW3Designs

Full Access Member
Joined
Jan 6, 2021
Posts
119
Reaction score
28
Location
New York
Getting a frequent suspension fault, used to be once in a while when I selected a height, but now it happens daily just driving. The code on my scanner is C1 A1 3-64/ Pressure doesn’t decrease when venting gallery. A little digging leads me to a bit of info on a clogged exhaust silencer? I’m thinking others have been down this path, hoping someone can get me started in the right direction to troubleshoot / fix this.
 

jlach993

Full Access Member
Joined
Mar 13, 2013
Posts
461
Reaction score
175
Location
Fresh Meadows Queens NY
You need a compressor. I got that message and it gave me 2 years until it finally quit on me. A simple start/restart got rid of the fault. Sometimes i just ignored it and it went away during the drive. When it does quit though it’ll say normal height available. Either the desiccant inside the canister is all caked up from moisture and blocking the exhaust valve or the pump internals are failing. Theres a kit that’s available on amazon/ebay. That refurbishes the canister. That’s basically what makes these pumps go out. I however didn’t want to deal with the repair and wanted a new hitachi pump. This one lasted 11 years. I figured the rebuild would only give me a few years if that.


X8R AIR SUSPENSION COMPRESSOR DRYER REPAIR KIT COMPATIBLE WITH LAND ROVER LR4 / DISCOVERY 4 2010-ON, PART # X8R40 / X8R0040 https://www.amazon.com/dp/B00SYYPKCC/ref=cm_sw_r_cp_api_i_F82PHXRVE763EYVTX5J4
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
123
Reaction score
33
Location
Portland, OR, USA
I did the desiccant replacement and it was straight forward. It's straight forward if you want to give it a shot.
 

MW3Designs

Full Access Member
Joined
Jan 6, 2021
Posts
119
Reaction score
28
Location
New York
I am going to try the desiccant replacement and see what happens. The plan is to sell my LR4, I love it, but it needs timing chains done, and I don't have the time to get it done myself.
 

greg00

Member
Joined
Jan 25, 2021
Posts
14
Reaction score
3
Location
Europe
I have the same fault. Used to be once in a while, now always. Sometimes immediately at start or after a few miles.
I changed compressor, air tank, front and middle valve blocks. Even replaced the exhaust valve on the new compressor because I thought it was broken from the beginning.
I'm going to change rear valve block next.
Any suggestions ?
 

Latest posts

Members online

Forum statistics

Threads
35,318
Posts
207,638
Members
29,565
Latest member
ABDO
Top