Problem when locking the car.

Georgemera1

Well-Known Member
Joined
Mar 7, 2012
Posts
68
Reaction score
11
My 2012 LR4 started to give me a problem since couple of days ago. When locking it the car beeps twice and the side mirrors don't fold in. The car gets locked but doesn't work normally.
Sometimes it works fine but most times now it is doing what I described above.
Can someone let me know if you had this issue and what the solution can be?

Thanks in advance,


George,
 

greiswig

Full Access Member
Joined
Mar 1, 2021
Posts
447
Reaction score
140
Location
Oregon
It might help if you elaborated on "doesn't work normally." But...other parts of it make it sound like maybe it thinks something is ajar, like the hood? Or maybe one of the sensors/wiring that detects an open hood, door, or hatch is bad? Maybe start with the simplest and check your display, where an overhead view of the vehicle will show if it thinks something is open.
 

djkaosone

'11 LR4 HSE LUX 5.0L V8
Joined
Oct 26, 2015
Posts
727
Reaction score
452
Location
SoCal
My 2012 LR4 started to give me a problem since couple of days ago. When locking it the car beeps twice and the side mirrors don't fold in. The car gets locked but doesn't work normally.
Sometimes it works fine but most times now it is doing what I described above.
Can someone let me know if you had this issue and what the solution can be?

Thanks in advance,


George,
This usually happens to me when I mess with the battery. If the battery was disconnected for any reason, my side mirrors have a weird hesitation of folding in.

You can simply do a hard reset. Roll down your driver's window, pop the hood, close your unlocked car door, remove both pos and neg cables from the battery, let sit for 10 mins, let the pos and neg loose cables touch for 3 seconds (you can use a wrench to bridge; cables CANNOT be connected to the battery [you have been warned]), reconnect the cables to the battery, and try it again.

You may need to reprogram the front automated windows; with windows rolled up, hold the up switch for 10 seconds, and let go.
 

TrinidadLR4

Full Access Member
Joined
Nov 27, 2018
Posts
455
Reaction score
265
Location
NE Washington DC
when this happens, the car thinks one of the doors or the hatch aren't fully shut. If they are all shut, there is a sensor at fault somewhere or a short.
 

Georgemera1

Well-Known Member
Joined
Mar 7, 2012
Posts
68
Reaction score
11
when this happens, the car thinks one of the doors or the hatch aren't fully shut. If they are all shut, there is a sensor at fault somewhere or a short.


Thanks for the reply, I don't know what to do, should I check the fuse box?
 
Last edited:

TrinidadLR4

Full Access Member
Joined
Nov 27, 2018
Posts
455
Reaction score
265
Location
NE Washington DC
I would say it's one of the individual door push pin sensors, or the latch sensor in the tailgate. It might throw a code too, check that if you have an IID tool.
 

greiswig

Full Access Member
Joined
Mar 1, 2021
Posts
447
Reaction score
140
Location
Oregon
As I said above, if you look at the display behind your steering wheel, there is a view that will tell you which door it thinks is still open if that is the issue.
 

Stuart Barnes

Full Access Member
Joined
Oct 27, 2019
Posts
432
Reaction score
226
Location
Los Angeles
Also. Have you checked the key batteries. When mine were on the way out they would do sone strange stuff like this.
 

f1racer328

Full Access Member
Joined
Apr 18, 2017
Posts
462
Reaction score
208
Location
AZ
I've been having this problem once every few months. I was also kind of thinking it was my key fob battery going out, since when I get the key closer to lock my car it works (I lock it with the buttons on the door)

OP are you locking your car with the key fob button, or the door handle button?
 

Latest posts

Staff online

  • joey
    Custom Rover Accessories

Forum statistics

Threads
35,395
Posts
208,295
Members
29,697
Latest member
Madtoro8
Top