Replaced my AMK Compressor with a new one today. Now my venting is almost embarrassingly loud.

Turismo Kid

Member
Joined
Dec 26, 2021
Posts
16
Reaction score
11
Location
So Cal
I'm a noob so I might have done something wrong but it's a pretty straightforward forward job. It vents loud when going to access mode. When I go up to off-road mode there's a quick pressure release when the compressor reaches appropriate pressure. It's loud enough that I might startle someone standing there not expecting it with their back to the vehicle. You could hear the previous AMK but it was MUCH quieter when venting. Are there AMK models that are known for this? I just got whatever they were selling at FCP Euro, it came with appropriate kit for the LR4, so I assume it was a model appropriate for the vehicle. Maybe I installed the shroud incorrectly, but I'm not sure how? Any lessons learned from those of you that have worked through this?
 

Rover Range

Full Access Member
Joined
Jun 13, 2022
Posts
132
Reaction score
46
Location
Texas
The exhaust port is connected to a hose that runs up into the fender well area. Maybe the hose popped off.
 

Turismo Kid

Member
Joined
Dec 26, 2021
Posts
16
Reaction score
11
Location
So Cal
Thanks for the replies. The elbow fitting for the exhaust blew right off the compressor. It’s not a break, just like it was never cemented on. I’ll look into a proper cementing adhesive and it should be a quick fix.

Thanks again for being a sounding board and offering some some solid advice.
 

Latest posts

Forum statistics

Threads
35,624
Posts
210,390
Members
29,902
Latest member
saopesoko
Top