Replacing TCS intermittent cruise control issues park code

Fuji4

Full Access Member
Joined
Jul 26, 2014
Posts
489
Reaction score
222
I have had the P0850-00 code and a shifter that stays in the elevated position for while. Cruise control has not worked properly in a while. I was able to put the car in N, clear the codes, put in parking brake, turn off the car, turn it back on and drive off and be able to use cruise control every time. Which is super annoying. That basically avoids putting it into P and getting that error. Anyway I ordered a new (used) TCS on eBay and will install it this week. Hopefully that rights the situation. Not sure if one of my kids spilled something into the old one or what. I disassembled it and the circuit board looked fine no burnt traces. The lift motor is dead but the part isn’t that expensive so I just got another one.
 

Attachments

  • 6186B55B-1EE2-4758-A78B-0D08AF9C9D16.jpeg
    6186B55B-1EE2-4758-A78B-0D08AF9C9D16.jpeg
    119.8 KB · Views: 20
  • AC453D2F-D1FC-4A1F-91CB-E842D392A5EB.png
    AC453D2F-D1FC-4A1F-91CB-E842D392A5EB.png
    171.7 KB · Views: 16

Czeczenski

New Member
Joined
Aug 11, 2022
Posts
2
Reaction score
0
Location
Poland
Hello.
I have the same error code and smptoms.
Did you change TCS?
Did it help?
 

Fuji4

Full Access Member
Joined
Jul 26, 2014
Posts
489
Reaction score
222
Hello.
I have the same error code and smptoms.
Did you change TCS?
Did it help?
No. The true root of the problem with CC and error was that the transmission had leaked oil on the electronic connection at the mechatronic unit. I think it was a leaky sleeve seal. We dropped the unit and swapped the sleeve seal and it went away and never returned.
 

Czeczenski

New Member
Joined
Aug 11, 2022
Posts
2
Reaction score
0
Location
Poland
I understand. Thanks for quick reply.
I hope mine failure is simpler.

I have some other codes.
P084F-11 (P/N output switch circuit shorted to the ground),

and

U0401-81 (Invalid data recieved from ECM/PCM).

I have this car since yesterday.

All suggestions will be appreciated.

I have another Disco4 (2013 SDV6) with broken crankshaft bearings, so firstly I will try with TCS and TCS plugs.

Will see.
 
Last edited:

Latest posts

Forum statistics

Threads
35,455
Posts
208,789
Members
29,736
Latest member
Jtigger012
Top