Some codes. Please assist.

ycharlie

Full Access Member
Joined
Aug 11, 2010
Posts
315
Reaction score
0
Hi all, pulled these codes from the gap tool. Car functions fine, just annoying seeing these codes. Any assistance would be greatly appreciated!

ACM-Audio System

  • U2100-00 (2B) Initial configuration is not complete
    ( on 13-06-2022 14:05:34 at 207595 km )
  • U0159-00 (2A) Lost communication with parking assist control module
    ( on 13-06-2022 14:04:44 at 207595 km )
DDM-Driver Door

  • B1D06-15 (6C) Left turn signal circuit - General electrical failure - circuit short to battery or open
    ( on 06-05-2022 15:09:47 at 205807 km )
FEM-Navigation

  • B119F-13 (2C) GPS antenna - General electrical failure - circuit open
    ( on 12-06-2022 14:57:32 at 207561 km )
IPMB-Camera

  • B12BD-31 (28) Rear camera - Frequency modulation/pulse width modulation failure - no signal
    ( on 20-04-2022 20:53:41 at 203912 km )
  • B12BE-31 (28) Front left camera - Frequency modulation/pulse width modulation failure - no signal
    ( on 01-03-2024 06:52:50 at 0 km )
PDM-Passenger Door

  • B1166-15 (6C) Front right puddle lamp output - General electrical failure - circuit short to battery or open
    ( on 06-05-2022 12:20:20 at 205797 km )
  • B1D07-15 (6C) Right turn signal circuit - General electrical failure - circuit short to battery or open
    ( on 30-04-2022 08:57:55 at 205198 km )
 

ryanjl

Full Access Member
Joined
Dec 31, 2015
Posts
2,724
Reaction score
1,558
Location
KCMO
Have you cleared the codes to see if any come back?
 

ryanjl

Full Access Member
Joined
Dec 31, 2015
Posts
2,724
Reaction score
1,558
Location
KCMO
I know you said your battery is good, but how old is it? There have been several instances before of people thinking their battery was good, only to discover it wasn't.
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
255
Reaction score
81
Location
Portland, OR, USA
When you open the passenger door, does the puddle light on the bottom edge of the door light? Mine was out, turned out the monkey who replaced the door glass from a smash & grab incident ripped the door panel off when trying to remove it (top screw mount is full on ripped), and yanked the bulb connector out. I had to pop the door trim off again to feed the power cable back through the hole to reconnect it. Code is now gone.

I wonder if the indicator codes related to bulbs for those in the mirrors, I would have expected those to be LEDs, but maybe they're incandescent.

GPS antenna I see sometimes, and I tore the dash apart to see if there was a loose connection - there wasn't, and the code has come and gone intermittently.
 

ycharlie

Full Access Member
Joined
Aug 11, 2010
Posts
315
Reaction score
0
The lights work. However, I did get aftermarket puddle lights that shows the LR logo on the floor. Also the side blinkers too since I replaced them with leds. Will try to find the original housings tomorrow and swap back to see if they still trigger code. As for gps I have no idea. It just started happening some years ago and I lost connectivity to my tpms so I had to disable them.
 

ftillier

Full Access Member
Joined
Jul 27, 2021
Posts
255
Reaction score
81
Location
Portland, OR, USA
LEDs don't have the same resistance, so will trigger those faults as at startup the system will check for continuity expecting a filament bulb. Some LED kits come with resistors to fool the computer and be error free.
 

Latest posts

Members online

Forum statistics

Threads
35,552
Posts
209,702
Members
29,803
Latest member
Sandy007
Top