Steering wheel button Backlighting and horn not working properly

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Joined
Aug 4, 2020
Posts
24
Reaction score
25
Location
Dallas TX
I noticed a couple months ago that the back lighting on the steering wheel buttons on my 2008 LR3 were cutting out when the wheel was hovering around the normal centered position, but a slight turn of the wheel and they’d pop back on. Progress to today and they are now always off. In addition the horn buttons don’t work. After a Neanderthal inspired research moment I discovered that they all work perfectly if you push slightly on the top of the central airbag unit. So when I need to see a button at night or honk the horn I just press the top center and it all works. Not a great fix, but functional. Now, my state inspection is due and I need a working horn to pass... a one-step horn honk will be required. I’ve watched a few YouTube videos on removing the airbag and accessing the wires and such beyond. Before I did that I wanted to see if others have had this happen and what to look for.
Thanks!
 
Joined
Aug 4, 2020
Posts
24
Reaction score
25
Location
Dallas TX
Yes, the only buttons that don’t function now are the horn buttons. The rest all work normally, it’s just the back light on the buttons that don’t work. The voice command and phone buttons are the same too.
 

remember5

Full Access Member
Joined
Nov 26, 2014
Posts
408
Reaction score
126
I second the clock spring diagnosis. Usually the cruise is affected as well.
 

Latest posts

Members online

Forum statistics

Threads
36,247
Posts
217,851
Members
30,491
Latest member
DonnaRocket
Top