Weak windshield washer spray

Discussion in 'LR3' started by Ttweedy, Jun 4, 2018.

  1. Ttweedy

    Ttweedy Member

    Posts:
    24
    Likes Received:
    1
    Joined:
    Jul 17, 2016
    Location:
    Twin Cities
    So has anyone had the issue with a weak washer spray. My assumption it's needing a new pump.

    Thanks,
    Todd
     
  2. remember5

    remember5 Full Access Member

    Posts:
    55
    Likes Received:
    10
    Joined:
    Nov 26, 2014
  3. Ttweedy

    Ttweedy Member

    Posts:
    24
    Likes Received:
    1
    Joined:
    Jul 17, 2016
    Location:
    Twin Cities
    Thx, I checked the nozzles and they appeared to be clear. I rooted around with a pin and nothing.

    Thoughts?
     
  4. remember5

    remember5 Full Access Member

    Posts:
    55
    Likes Received:
    10
    Joined:
    Nov 26, 2014
    I would just start at the reservoir and try to trouble shoot from there. If you don't have a shop manual can see if I can upload the wiper section.
     
  5. Ttweedy

    Ttweedy Member

    Posts:
    24
    Likes Received:
    1
    Joined:
    Jul 17, 2016
    Location:
    Twin Cities
    I don’t, that would be awesome! Thx!
     
  6. remember5

    remember5 Full Access Member

    Posts:
    55
    Likes Received:
    10
    Joined:
    Nov 26, 2014
    I'm sorry to took me so long to send this, I never think about it when I'm at home, attached is the overview, if you want a single component let me know, there are about 8 sections under windscreen washing system.
     

    Attached Files:

  7. DPetty2994

    DPetty2994 Full Access Member

    Posts:
    56
    Likes Received:
    4
    Joined:
    Sep 7, 2017
    Location:
    DFW
    Had a similar issue.

    Ended up being my Resovoir was cracked, and simply had a small amount in the tank—so not enough fluid to prime/allow much pressure to build up.
     
  8. Ttweedy

    Ttweedy Member

    Posts:
    24
    Likes Received:
    1
    Joined:
    Jul 17, 2016
    Location:
    Twin Cities
    Thx, mine will hold fluid no problem. It just arch's it to the bottom half of the windshield. When your driving it's no good at all.
     
  9. DPetty2994

    DPetty2994 Full Access Member

    Posts:
    56
    Likes Received:
    4
    Joined:
    Sep 7, 2017
    Location:
    DFW
    Probable that the pump is failing...
     
  10. DPetty2994

    DPetty2994 Full Access Member

    Posts:
    56
    Likes Received:
    4
    Joined:
    Sep 7, 2017
    Location:
    DFW
    Try replacing the nozzles first.

    Then--if that doesn't fix it--disconnect the tubing to one of the nozzles, and hook to a long tube from another car's nozzle(that you've disconnected)

    Basically--you're using Car B's pump to test YOUR LR's nozzle.

    If it squirts great--you know the pump is shot.
     

Share This Page