Well crap!

Robin Parsons

Active Member
Joined
Jan 25, 2018
Posts
43
Reaction score
17
Location
Austin, TX
Well, I guess after 103599 miles of faithful and fairly trouble free service... I just joined the LR4 disaster club. Cruising along at 65 to 70, hear a slight ticking from under hood /floorboards. Looked back in RV mirror to see blue haze, immediately let off gas and limped over withing .25 miles and as I edged over, the MIL flash for 1 to 2 seconds as the engine stalled. Oil level check...empty. bottom covered with oil, top covered with coolant. No warning. Other than the obvious total engine failure, any observations or ideas? Comiseration?
 

avslash

Full Access Member
Joined
Nov 22, 2011
Posts
1,182
Reaction score
1,011
Location
The Lone Star State
I will drink a beer in memory of your block on this Thursday evening.

Any idea what killed it?

Get in touch with hungrwelder from Instagram and LS swap it.

That is my rough plan if my block detonates. I really hate the thought of dropping 10K+ to replace a trouble prone LR mill with another trouble prone LR mill.
 

PaulLR3

Full Access Member
Joined
Mar 11, 2006
Posts
1,401
Reaction score
527
Location
Boston
Oh no, sounds like the engine is certainly done. The way I look at it, once a vehicle gets to 100K miles I figure I got my use out of it. It will be a tough decision if you should just move on or drop in a rebuilt engine. Defender delivery is now months behind, but I bet you could get an amazing deal on a Discovery 5 that is sitting on a lot. I'd start the bidding at about 20% off sticker price.
 

Troy A

Full Access Member
Joined
Sep 28, 2019
Posts
346
Reaction score
250
Location
San Francisco, CA
Well, I guess after 103599 miles of faithful and fairly trouble free service... I just joined the LR4 disaster club. Cruising along at 65 to 70, hear a slight ticking from under hood /floorboards. Looked back in RV mirror to see blue haze, immediately let off gas and limped over withing .25 miles and as I edged over, the MIL flash for 1 to 2 seconds as the engine stalled. Oil level check...empty. bottom covered with oil, top covered with coolant. No warning. Other than the obvious total engine failure, any observations or ideas? Comiseration?
I'm sure this is fear on my part (OMG will this happen to me?) but I'm curious to know the general state of the vehicle and its maintenance. I mean, was this a very well known, well-maintained vehicle and this whole thing was an unpredictable fluke? Or was it behind on maintenance? Or did you have any recent inklings? The thought that my LR4 (turning over at 80,000 miles now) would just up and die at 105K is...unpleasant to say the least. Sorry to hear about your situation. I too would love to hear the outcome of this.


Sent from my iPad using Tapatalk
 

ktm525

Full Access Member
Joined
Mar 26, 2017
Posts
2,192
Reaction score
983
Location
alberta
Well, I guess after 103599 miles of faithful and fairly trouble free service... I just joined the LR4 disaster club. Cruising along at 65 to 70, hear a slight ticking from under hood /floorboards. Looked back in RV mirror to see blue haze, immediately let off gas and limped over withing .25 miles and as I edged over, the MIL flash for 1 to 2 seconds as the engine stalled. Oil level check...empty. bottom covered with oil, top covered with coolant. No warning. Other than the obvious total engine failure, any observations or ideas? Comiseration?

Overheat?
 

ktm525

Full Access Member
Joined
Mar 26, 2017
Posts
2,192
Reaction score
983
Location
alberta
With my 2010 at 115k miles if something catastrophic happens it is being sold as is where is or I will part it out. I doubt I would put $5k into it let alone $10k.
 

Robin Parsons

Active Member
Joined
Jan 25, 2018
Posts
43
Reaction score
17
Location
Austin, TX
Thanks for all your thoughts. I will keep the group posted. Just for info...

The body and interior are pristine. Not good or great but virtually as new. Perfect dash leather everything. I have maintained a vehicle like this.

All maintenance has been done as scheduled or early. Oil, air filters every 6 to 8k, with OE oil. Never driven hard.

Just upgraded to heavy duty slotted brakes, suspension bushings new, a/c and trans serviced at 85k, new batteries, changed brakes, PS fluid, etc.

SC coupler, timing chain and coolant fittings on order

Waterpump changed about 3000 miles ago. Wondering if it could be related?

Meticulous maintenance, and not even the slightest warning until the last moment. I am just in shock. Was diligently prepping to go another 120k. Im in shock...and bummed

20200509_182247.jpg


20200509_182219.jpg


20200509_181259.jpg
 

Members online

Forum statistics

Threads
35,556
Posts
209,742
Members
29,809
Latest member
macdven
Top