Suspension Fault Diagnosis

Discussion in 'LR3' started by sushisean, May 9, 2009.

  1. sushisean

    sushisean Full Access Member

    Posts:
    153
    Likes Received:
    0
    Joined:
    Sep 26, 2008
    I've been getting the "suspension fault"warnings every time I go offroading lately, even occasionally on road. I've inspected the compressor and see nary a scratch on it so I don't think physical damage to that at least is the problem.

    I had this light along with many others popping up on the dash a couple weeks ago, the dealer found and fixed a wheel speed sensor. Now only this one light remains.

    What things can cause this? Why do I typically only see it when the suspension is at a height other than ride?
     
  2. USAFbuckeye

    USAFbuckeye Full Access Member

    Posts:
    280
    Likes Received:
    1
    Joined:
    Dec 8, 2008
    What fault is it specifically and where is the suspension (ride height-wise) when you get the warning?

    I had a buddy who had an 05, V6 LR3 that every time he was in extended mode and over extended a wheel (buy hanging it off a ledge or rock) would get a suspension fault. however, when ever he selected normal ride height and restarted his truck, the fault would go away and stay away until next time.
     
  3. sushisean

    sushisean Full Access Member

    Posts:
    153
    Likes Received:
    0
    Joined:
    Sep 26, 2008
    It's in std Off-Road height. Cycling the ignition used to clear the amber alert for a short period of time, sometimes the remainder of the journey. This time however it only cleared it for a few seconds.

    Each time it gives me a warning saying special programs are unavailable, and once it said only normal height was available. The truck always stayed in off road height though.

    One frustrating thing was the dealer said there was no way to pull up these codes after they have gone away. So I can't just pull in and have them look at a history on the car of the warnings that have come on. I find that hard to believe, but it makes me think if I can't go in there with the warning on then they can't do anything about it.
     
  4. USAFbuckeye

    USAFbuckeye Full Access Member

    Posts:
    280
    Likes Received:
    1
    Joined:
    Dec 8, 2008
    I hear ya, it is frustrating!

    Mine is in the shop right now for similar problems. The dealer says it is the compressor. I could hear air leaking from one of the line coming from the compressor.

    My guess is since you get the warning every time, minutes after starting that it is mechanical failure versus an electrical (sensor) failure.

    Will the faults reproduce while at the dealer? If so, they "should" be able to handle the problem.
     
  5. sushisean

    sushisean Full Access Member

    Posts:
    153
    Likes Received:
    0
    Joined:
    Sep 26, 2008
    Just to give an update here. The problem started happening ON ROAD as well. I took it to the dealer and they added my vehicle to the 10 they currently have that are waiting compressor replacements. They say every dealer in the nation is getting hit up for these right now and that it could be a couple weeks before I have my truck back.

    Ironically enough I went and did the LR experience in Carmel this past weekend and we got a suspension fault. I teased the guy pretty good on it :)
     
  6. gmoney

    gmoney Full Access Member

    Posts:
    103
    Likes Received:
    0
    Joined:
    Jan 17, 2009
    Mine is doing the same thing; I am surprised at the backorder time.
    My dealer told me to keep driving but let them know if things change. The warning I am getting is the orange one not red.
    Now I wonder if I should be driving.
     
  7. sushisean

    sushisean Full Access Member

    Posts:
    153
    Likes Received:
    0
    Joined:
    Sep 26, 2008
    I am getting the orange one. For the first time, I got the overheat warning on the dash saying I couldn't raise height until the system cooled. I called the dealer today to say I'd like to pickup my car and bring it back when they get the part. They said I should not continue to drive because the heat will damage more parts.

    For what it's worth, I trust my dealer they've always treated me well and given me solid info. She did tell me that last week they had one in for the same problem, it looked like it was going to be two weeks for the part, but it only took two days. Apparently they have no tracking info on this stuff. I will post back once it's fixed.
     
  8. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,139
    Likes Received:
    2
    Joined:
    Jan 6, 2006
    I have had a few different kind of suspension faults. The first variety are like that described above and it was a long time ago. It would come on and say special programs off and all that crap. It would go away with a reboot but once in a while come back...the dealer also said it could not find a fault and I believe them. Some faults leave a history, some do not.

    Anyway, it turned out to be the electrical harness. It was not insulated well and got wet. The dealer replaced the ECU, the harness and packed it in there real good so that the problem would not recur, and it hasn't. That was 3 years ago.

    I got another fault recently that had more to do with getting my suspension out of the sensor's range. Meaning I was unwittingly trying to access a height greater than super-extended mode (I was high-sided and I run the rod-mod). This fault cleared AND it left a history and the dealer read it for me. No parts needed though.

    I got a new compressor about a year ago. I was in for something (don't remember what) and the dealer claimed that the rig through a fault while in their shop and so they swapped the compressor out! Hmmm....
     
  9. sushisean

    sushisean Full Access Member

    Posts:
    153
    Likes Received:
    0
    Joined:
    Sep 26, 2008
    I've read several places that the compressor is a big issue they found in the last year, and that they are actively replacing them. You got lucky in that they did it without even being asked!
     
  10. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,139
    Likes Received:
    2
    Joined:
    Jan 6, 2006
    Sounds like it! I don't remember exactly when they changed it, but it wasn't long ago.
     

Share This Page