Electrical Connectors

Discussion in 'LR3' started by Ruper, Aug 12, 2019.

  1. Ruper

    Ruper Member

    Age:
    50
    Posts:
    17
    Likes Received:
    2
    Joined:
    Jun 16, 2019
    Location:
    Chesapeake, VA
    Where (other than a junkyard) could I find an electrical connector. Just pulled a wire out of my fuel temperature sensor plug.
    Or does someone know how to disassemble the plug to place the wire back in. I think I literally just pulled the wire out of the terminal clip.
     
  2. Ruper

    Ruper Member

    Age:
    50
    Posts:
    17
    Likes Received:
    2
    Joined:
    Jun 16, 2019
    Location:
    Chesapeake, VA
    I assume Crickets means no one has a source. Well did a little digging at DEL CITY. They are an electrical distributor that usually serves commercial business. However you and me can order from them. I found the electrical terminals there, GT-150 is the part number, I also ordered a couple plugs from them however nit sure they will match individual plugs found on our machines.
    As far as my issue(s) I did find that a loose wire that come from the Fuel Temp Sensor was my issue relating to the P0116 and P0186 fault codes I was getting. Once I sorted that loose wire out by robbing a plug from a Ford Expedition from the J yard, only had to trim off two prongs off the sensor, but it worked I am CEL free for the time being. Also the idle has resolved now at 690 rpm's so the gas mileage is improved to a whopping 16.5 mpg.
    That's as good as I expect from the 4.4 rolling Lead Brick I own.

    Here's a link not sure if they will deal internationally but I ordered a bunch.
    https://www.delcity.net/store/GT-150-Female-Housing/p_810478.h_810479

    https://www.delcity.net/store/GT-150-Terminals/p_810491.h_810492

    https://www.delcity.net/store/GT-280-Terminals/p_915037.h_915039
     

Share This Page