Quijote
Reaction score
316

Latest activity Postings About

    • Quijote
      Quijote reacted to itsaguything's post in the thread Highest mileage LR4? with Like Like.
      @Quijote , If I ever see a Mass. plated LR4 in my haunts, be prepared for a beep. @ryanjl , too true. Or as @BigBriDogGuy is...
    • Quijote
      Quijote reacted to ryanjl's post in the thread Highest mileage LR4? with Like Like.
      I can tell you what's wrong with that math: the hypothetical. The sub $10k LR4 is sub-$10k because it needs a lot of maintenance...
    • Quijote
      Quijote reacted to Al Pizzica's post in the thread Highest mileage LR4? with Like Like.
      Thanks for this, you guys are making me feel like our 2013 with 108k is a spring chicken and I'm banking it is. It's paid off, it ain't...
    • Quijote
      Quijote replied to the thread Highest mileage LR4?.
      True. And a scary prospect for prospective buyers of used LR4s.
    • Quijote
      Quijote replied to the thread Highest mileage LR4?.
      Hey, it is THE family car for trips. This thing has been everywhere including Canada dozens of times. It's also the only way to...
    • Quijote
      Quijote replied to the thread Highest mileage LR4?.
      I'm at the opposite end. Ours is at 57.5k miles.
    • Quijote
      Quijote replied to the thread Failed emissions - no faults.
      I ran IID tool yesterday and saw a couple of strange ground faults. One re: an antenna and another (multiple instances) re: the e-brake...
    • Quijote
      Quijote replied to the thread Failed emissions - no faults.
      Yeah, but this was way more than that. My son called and i could hear the ringing via the car but nothing showed up on the screen. I hit...
    • Quijote
      Quijote replied to the thread Failed emissions - no faults.
      So, coincidentally, the BT phone connection acted up big time just now. I’m thinking that it’s the 5.5-year old battery acting up. I’ll...
    • Quijote
      Quijote replied to the thread Failed emissions - no faults.
      My wife took a photo and sent it. That’s literally all it says. Drive it more and test again.
    • Quijote
      Quijote replied to the thread Failed emissions - no faults.
      Hmmm. I was going by what my wife told me. It seems it says the vehicle is not ready because it recently was reset. I don’t recall doing...
    • Quijote
      Quijote posted the thread Failed emissions - no faults in LR4.
      As the title mentions, 2013 LR4 failed Massachusetts inspection for emissions. I figured it would be a bad O2 sensor, but IID Tool shows...
  • Loading…
  • Loading…

Latest posts

Members online

Forum statistics

Threads
36,178
Posts
216,949
Members
30,438
Latest member
MosheFrost
Top