Disco 4 Smart Fob Issue

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

BourneFree

New Member
Joined
Nov 8, 2023
Posts
1
Reaction score
0
Location
Derby U.K
Hi, just wondering if anyone can help me. I have a Disco 4 2014 3Ltr D SDTV. I took out the BCM (passenger side U.K mod) to replace the sr drain plug. I spliced the drain hose at the A pillar and struggled to get the new hose through the mass of wires out to the inner wing drain hole. I managed it and was as careful as possible not to do any electrical damage to that wired area.

When I fitted the BCM again everything worked correctly on the disco, apart from the smart key fob. It unlocked the disco, turned off the immobiliser, started the engine but when I went to lock the car it didn't lock any of the doors, just the tailgate - and didn't pull in the mirrors.

So I disconnected the BCM again; checked that all the plugs were sitting correctly in the BCM, all the earths in that area were clean and oiled, all the adjacent plugs were sitting correctly and undamaged and checked that all the wires in the area that I had been working in had not been nicked. I couldn't find any issues.

I then took it to Derby 4x4 in Derby, UK, unfortunately their sparky had not long died. To be fair they had a look and checked everything I had done and everything checked out. They also checked the pins in the BCM plug and socket for this system and everything was correct. They recommended I go to an Autosparky they now use, so I phoned and as soon as I mentioned Land Rover they said they couldn't help - I never even got to say what the issue was and how it occured...strange.

Before I see if I can get an Autosparky to take a look, I was just wondering if anyone else has encountered an issue of this type, removing the BCM in a RHD model of this age. Basically so I can let the Autosparky have a starting point so I don't get a shirt-off-my- back repair bill.

Before I took the BCM off everything was working perfectly and everything is still working perfectly, apart form this issue. There were no signs of the BCM failing before this and still aren't any. There has never been an issue with any of the door actuators (all 4 can't fail at once surely!). So does anyone know if there are door or mirror wires in the bulk head below the A pillar and inner wing drain hole where the BCM sits? If so, it's possible I may have nicked one. Electrical issues are so far beyond my ability so please, just a yes or no if there are wires there.

To me it seems the smart key is still communicating with the BCM and with the KVM as it is locking the tailgate. Is there any way to resynchronize the smart key to lock the doors and fold the mirrors? I bought the GAP tool before this occurred, to program 2 new keys and I've sent all the ECU info to Patrick at GAP and they have given me the correct software to flash my specific KVM ECU but even with the update I still get an E9 error on the GAP tool, so I can't even program a new key/s to resolve not having a working smart-fob.

Any insight would be very much appreciated. Cheers.
 

Latest posts

Members online

Forum statistics

Threads
36,182
Posts
217,029
Members
30,444
Latest member
LR4TAZZ
Top