2008 LR2

Discussion in 'LR2' started by Stephbstuntn, Aug 3, 2017.

  1. Stephbstuntn

    Stephbstuntn New Member

    Age:
    34
    Posts:
    4
    Likes Received:
    0
    Joined:
    Aug 3, 2017
    Location:
    Amarillo tx
    Hello i am new to the group. I have a 08 lr2 with 140,000 miles. Im having starting troubles i replaced the starter. Charged my battery. Put a obdII reader on it and no codes came up. Can anyone help me please?
     
  2. Stephbstuntn

    Stephbstuntn New Member

    Age:
    34
    Posts:
    4
    Likes Received:
    0
    Joined:
    Aug 3, 2017
    Location:
    Amarillo tx
    Im sorry i shouldve said all light come on but i get no crank at all.
     
  3. Bblucas

    Bblucas New Member

    Age:
    69
    Posts:
    1
    Likes Received:
    0
    Joined:
    Aug 19, 2017
    Location:
    Illinois USA
    I am having the same issue, were to able to determine the proble?
     
  4. gmfain

    gmfain Active Member

    Posts:
    31
    Likes Received:
    1
    Joined:
    Sep 2, 2009
    My daughter has an 08 LR2. I haven't had this issue, but curious to for cause and solution.
     
  5. Stephbstuntn

    Stephbstuntn New Member

    Age:
    34
    Posts:
    4
    Likes Received:
    0
    Joined:
    Aug 3, 2017
    Location:
    Amarillo tx
    Well first code scanner i used did not read land rovers. However i did get a friend that could. At that time my car was not running. I could not even get the dash board to light up. As soon as my friend connected his it lit up. It did say however every module in the car bad. EVERY MODULE!! I could not believe it. A couple days later i figured i would try to start it and it started rite up. Drove like nothing ever happened for a couple months. Then same thing happened again. One day it just decided to not start. I bought my own scanner from icarsoft waiting for it. Ill keep you updated. I keep reading everywhere about software updates. Does anyone know how i can find out if i need one?
     

Share This Page