2010 Land Rover LR4 - Suspension Fault

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

ac6567

New Member
Joined
Mar 4, 2023
Posts
1
Reaction score
0
Location
Oakland, CA
The suspension on my '10 LR4 is stuck on 'normal height' but is not raising. When driving, the ride is extremely bouncy from the front of the vehicle.

Here are my fault codes:
  • P0526 - Fan Speed Sensor Circuit
  • P0430 - Catalyst System Efficiency Below Threshold
  • C0031-64 - Front left wheel speed sensor
  • C0034-64 - Front right wheel speed sensor
  • U0421-68 - Invalid data received from ride level control module
  • U3003-62 - Battery voltage
No offroad driving.

Any suggestions as to what the issue is and the likely fix?
 

ryanjl

Full Access Member
Joined
Dec 31, 2015
Posts
3,048
Reaction score
1,810
Location
KCMO
You've got a bunch of unrelated codes. Clear them and see what comes back.
 

Cthehentz

Full Access Member
Joined
Feb 24, 2019
Posts
166
Reaction score
65
Location
Las Vegas
Check your battery voltage while engine is off and then while it is running, when my alternator failed the entire dash lit up. Resting voltage was around 12.5v, idling voltage is around 14.5v.
 

Al Pizzica

Full Access Member
Joined
Jul 9, 2019
Posts
202
Reaction score
118
Location
PA
Yeah, whenever battery voltage comes up, address that code first and chances are the others will clear.
Both of our LR4s threw all kinds of random codes when the batteries were dying.
 

Latest posts

Members online

Forum statistics

Threads
36,293
Posts
218,394
Members
30,506
Latest member
Carbonlink
Top