Season's Greetings from Mesa, AZ

Discussion in 'Introduction' started by Easycool, Nov 27, 2018.

  1. Easycool

    Easycool New Member

    Age:
    68
    Posts:
    3
    Likes Received:
    0
    Joined:
    Nov 27, 2018
    Location:
    Mesa, Arizona
    Newbie here...with a 2007 Range Rover HSE. Looking to learn about technical support for my vehicle, and perhaps, I can impart some of my technical expertise as well.

    Best regards,
    Easycool
     
  2. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    9,792
    Likes Received:
    54
    Joined:
    Jun 28, 2004
    Welcome to the forum. Post a pic of the Range Rover... we like pics.
     
  3. Shaggy

    Shaggy Administrator Staff Member

    Posts:
    135
    Likes Received:
    16
    Joined:
    Jun 27, 2011
    Welcome to the forum. Did you just buy your 2007?
     
    Easycool likes this.
  4. Easycool

    Easycool New Member

    Age:
    68
    Posts:
    3
    Likes Received:
    0
    Joined:
    Nov 27, 2018
    Location:
    Mesa, Arizona
    Yeppers! Thanks Shaggy for responding to my post. The body and interior are in pristine condition. However, the mechanical leaves a lot to be desired. For example, the upper barb from the recovery tank broke at the "y" hose. Thus the engine overheated. Terrible situation. After block and vacuum tests it's certain that the head gasket and, maybe the sleeve slipped. Compression gasses are leaking into the coolant. A diagnostic check with an Actron CP9690 OBDII, cylinders 3, 4, 5, & 6 ate misfiring.

    So, after exhaustive searching, I found this site and am looking forward to interacting with folks that have Range Rovers. Perhaps we can work together to make our rides the best they can be.
     
  5. BikePilot

    BikePilot Full Access Member

    Posts:
    94
    Likes Received:
    32
    Joined:
    Aug 25, 2018
    Location:
    Golden Colorado (USA)
    Welcome!
     
  6. Shaggy

    Shaggy Administrator Staff Member

    Posts:
    135
    Likes Received:
    16
    Joined:
    Jun 27, 2011
    The "y" hose has been an issue. Ford part that alot of members have hated on and has gone bad with plenty of the LR they own. So is the motor still having issues due to the over heating?
     

Share This Page