Where does it go connected?

Discussion in 'LR3' started by Gabe, Jul 23, 2019.

  1. Gabe

    Gabe Member

    Age:
    37
    Posts:
    20
    Likes Received:
    0
    Joined:
    Jan 26, 2018
    Location:
    Illinois
    I recently have the suspension fault, the 2 roll over lights, and brake lights on. The truck wont raise at all, and during inspection i found a loose connector in the rear center of the truck right before the spare tire. But it's not the one that connects into the brake sensor but similar. Can someone please help? Pic is attached..[​IMG][​IMG]

    Sent from my SM-G955U using Tapatalk
     
  2. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,587
    Likes Received:
    142
    Joined:
    Jan 6, 2006
    Need way more info....that isn't a suspension fault (pictured). What specific things are happening...does the compressor come on? Do you have any fault codes that you can read? How is your battery voltage?
     
  3. Gabe

    Gabe Member

    Age:
    37
    Posts:
    20
    Likes Received:
    0
    Joined:
    Jan 26, 2018
    Location:
    Illinois
    I really appreciate your reply, at this point the compressor is only turning on once in a while when I start the vehicle. It wont raise at all dash shows cruise control off and a few more messages. And both roll over lights turn on. Last time I read the battery it showed 14.7


    Sent from my SM-G955U using Tapatalk
     
  4. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,587
    Likes Received:
    142
    Joined:
    Jan 6, 2006
    What does the dashboard information screen say when you try to raise it? What happens if you try to use a special program on Terrain Response?
     
  5. Gabe

    Gabe Member

    Age:
    37
    Posts:
    20
    Likes Received:
    0
    Joined:
    Jan 26, 2018
    Location:
    Illinois
    Special programs not available, cruise control not available, and when I hit the button to try and raise it both arrows flash,

    Sent from my SM-G955U using Tapatalk
     
  6. Gabe

    Gabe Member

    Age:
    37
    Posts:
    20
    Likes Received:
    0
    Joined:
    Jan 26, 2018
    Location:
    Illinois
    Suspension lowered

    Sent from my SM-G955U using Tapatalk
     
  7. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,587
    Likes Received:
    142
    Joined:
    Jan 6, 2006
    Are your brake and tailights good?
     
  8. Gabe

    Gabe Member

    Age:
    37
    Posts:
    20
    Likes Received:
    0
    Joined:
    Jan 26, 2018
    Location:
    Illinois
    Yes I found one missing and one burned bulb I will be replaced in the Morning. One from each taillight.

    Sent from my SM-G955U using Tapatalk
     
  9. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,587
    Likes Received:
    142
    Joined:
    Jan 6, 2006
    Okay do that, and make sure you get good quality bulbs and install them such that the filaments are vertical....and see how it goes. Wouldn't hurt to do a hard reset, either. If that doesn't work, I'd replace your Brake Switch next. Easy/cheap stuff first!
     
  10. samnt650

    samnt650 Full Access Member

    Posts:
    85
    Likes Received:
    8
    Joined:
    Feb 8, 2011
    Thats the brake wear sensor plug.
     

Share This Page