1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Introduction and Question

Discussion in 'LR3' started by AdamF, Dec 5, 2020.

Car Parts
  1. AdamF

    AdamF Member

    Age:
    121
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 4, 2020
    Location:
    Cleveland
    Hi Everyone. Disclaimer - I can barely change a light bulb - My wife drives a 2006 LR3 purchased new now with about 115,000 miles. She loves the truck! Last night leaving work, initially the truck ran fine, soon after the engine started revving and would not go over 30 MPH. After a couple miles the dashboard lights go on - break, transmission, suspension in amber and DCS - and then it started driving fine. I asked her to pull over and turn the truck off and back on. The same cycle happened again and she was able to make it home.

    My apologies if this is covered elsewhere - I searched this page and others and found similar stories with slight differences and multiple solutions.

    Not likely that I can fix this, just want to make sure when I take it in that we are not shaken down...not that that happens.

    Any guidance here would be appreciated.

    Happy Holidays!
     
  2. joey

    joey Custom Rover Accessories Staff Member

    Posts:
    10,198
    Likes Received:
    126
    Joined:
    Jun 28, 2004
    I moved this here to get better attention than the Intro section.
     
  3. AdamF

    AdamF Member

    Age:
    121
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 4, 2020
    Location:
    Cleveland
    Thank you
     
  4. remember5

    remember5 Full Access Member

    Posts:
    277
    Likes Received:
    97
    Joined:
    Nov 26, 2014
    Maybe start with battery/alternator checks, the auto parts store can do that for you.
     
  5. Houm_WA

    Houm_WA Full Access Member

    Posts:
    3,830
    Likes Received:
    213
    Joined:
    Jan 6, 2006
    I'm thinking the revving was actually the fan...is that possible, Adam?

    Check all your brake lights. Could be the brake switch, too.
     
  6. AdamF

    AdamF Member

    Age:
    121
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 4, 2020
    Location:
    Cleveland
    Thank you for the responses. I'll dig into it.
     
  7. ggrupea

    ggrupea Active Member

    Age:
    36
    Posts:
    41
    Likes Received:
    19
    Joined:
    Apr 1, 2019
    Location:
    Chile
    maybe you could check air filter, oil filter, gearbox filter. Sometimes when ignition or oil is not in good conditions, the car shows errors like yours. Another think you could check is the battery and alternator.

    Tell us how is going all
     
  8. macbright

    macbright Member

    Posts:
    15
    Likes Received:
    5
    Joined:
    Oct 8, 2016
    Location:
    Alma, GA
    I had a similar experience... Mine was replacement of the Brake light switch. Ordered it from British Atlantic Parts online.

    Go to your local Auto parts store ask them to do the computer diagnostics checkup... all major places like O'Riely's, AutoZone, Discount Auto Parts, or major chain in your area, it is no cost, FREE service. NOT WALMART!

    They should give you a printout with any error codes it finds. You can go online and find the actual item descriptions, with the codes, if they are not already in the printout report.

    This is how I determined some of the issues (small things) with my LR3. If this is not a clear solution in identifying you problem. It's time to take her in (the LR3) to your trusted Land Rover mechanic shop or dealer.
     
  9. AdamF

    AdamF Member

    Age:
    121
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 4, 2020
    Location:
    Cleveland
    Thanks everyone, you all are amazing. The latest is that I drove the truck for a couple days and all was fine. On the third day got a message that there was a transmission fault and then the truck would not change gears, maybe that was the "rev" and low speed my wife described. No dashboard lights though. I dropped it off yesterday to a local repair shop (not a dealership) but more a repair shop for foreign cars that does work on it, waiting for an update. As a side, they just did the 135k service. Thanks again!
     
    Last edited: Dec 9, 2020
  10. AdamF

    AdamF Member

    Age:
    121
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 4, 2020
    Location:
    Cleveland
    Well they ended up replacing the brake switch, which in doing more digging apparently is common in the LR and creates among other things the "Christmas tree" effect and transmission problems. Also they cleaned up some wiring from an old sirius radio that was rubbing with other wires. I'm embraced to say what I was charged. I will say that I am going to do my best in the future to take care of these things on my own. Thank you everyone. Hopefully this is put to bed for now. Happy holidays!
     

Share This Page