Anyone have any idea if this is a cause for concern? Suspension issue.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Daveykid

Supporting Member
Supporting Member
Joined
Jan 14, 2022
Posts
107
Reaction score
25
Location
Chicago
"21" L405 SV Autobiography Dynamic. Noticed the front left shock was lit up orange versus the others. Car is on a level surface in my garage with the engine running, wheels straight, nothing unusual. It was in access mode at the time. I raised the car to normal mode and to off-road mode and subsequently lowered it again and nothing changed. In those two other modes the light (orange) did revert back to white so it appears to only be happening in access mode. No, the suspension has never been modified and yes, the car is bone stock. I do have an IID Tool I could plug in to see if it's throwing any codes but I'm just going to go out on a limb and say it isn't. I didn't know if it meant it wasn't lowering to the level it should and I need to investigate further before it becomes a bigger issue or don't worry about it. I did ask the dealer and the response was "I don't know, I've never seen that before."

TIA!
Screen Shot 2024-04-08 at 2.25.13 PM.png
 

Rover Range

Full Access Member
Joined
Jun 13, 2022
Posts
617
Reaction score
340
Location
Texas
Probably a glitch with the left front height sensor.
If everything works, don't worry about it.
 

Latest posts

Members online

Forum statistics

Threads
36,351
Posts
219,085
Members
30,539
Latest member
ddvega
Top