1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Bucking" during acceleration

Discussion in 'LR4' started by Michael Conley, Oct 4, 2020.

  1. dlonesty

    dlonesty Active Member

    Posts:
    43
    Likes Received:
    9
    Joined:
    Mar 6, 2014
    Location:
    Seattle
    Now what to do?
     
  2. Michael Gain

    Michael Gain Full Access Member

    Posts:
    197
    Likes Received:
    81
    Joined:
    Dec 8, 2018
    Location:
    Clarksville, TN
  3. Michael Conley

    Michael Conley Member

    Age:
    44
    Posts:
    22
    Likes Received:
    4
    Joined:
    Jun 26, 2020
    Location:
    New Jersey
    So dropped it at the dealer to checkout, apparently it's due to misfires (which is also probably preventing my EVAP, EGR, and FUEL readiness). They're having a hard time tracking down the reason as there are no codes thrown. Will give ya an update when I find out but hopefully it should be covered by my dealer's 6-month limited warranty.
     
  4. maxx4wd

    maxx4wd Full Access Member

    Posts:
    97
    Likes Received:
    34
    Joined:
    May 5, 2016
    I had a very similar thing go on with my LR3- if it’s not the trans fluid first thing I’d check / replace is the MAF (make sure to use the OEM brand as these trucks are very finicky with the maf apparently). and then plugs and then fuel injectors... almost bet money it’s the maf and it won’t always give a clear code for it either just FYI.
     

Share This Page