1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Car doesn't start sometime in cold weather

Discussion in 'LR2' started by Tommilousis, Dec 16, 2019.

  1. Tommilousis

    Tommilousis Member

    Age:
    39
    Posts:
    6
    Likes Received:
    0
    Joined:
    Nov 16, 2019
    Location:
    Toronto
    It's a 2013 LR2. Looks like it's a battery issue because I've gotten that warning sign once or twice. However, I've been told it could also be a wiring issue because the battery was checked last winter and it was full and operating fine. The car also shakes once in a while when idling.

    Any other thoughts? I'm just curious. I want to know what to expect before taking it to the shop.

    Thanks!
     
  2. Phill

    Phill Member

    Age:
    65
    Posts:
    5
    Likes Received:
    0
    Joined:
    Sep 5, 2017
    Location:
    Sweden
    have you tried doing the two stage start up, ie push start button but don't put foot on brake, then repeat with foot on brake to start.
    There are others over here that swear by a extra earth wire from battery to starter ( you can find youtube videos on this)
    I have a calix battery charger wired in to trickle charge when i plug in my heater so battery is always in tip top condition. No idea if you can get this on your side of the pond ( assuming your in the USA)
     
  3. Tommilousis

    Tommilousis Member

    Age:
    39
    Posts:
    6
    Likes Received:
    0
    Joined:
    Nov 16, 2019
    Location:
    Toronto
    This is a great start. Thank you for the feedback. I'll check (close, in Canada)
     

Share This Page