1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Excessive rolling when turning or at speed

Discussion in 'LR4' started by Frank8, Jun 29, 2020 at 8:52 PM.

  1. Frank8

    Frank8 Full Access Member

    Posts:
    213
    Likes Received:
    43
    Joined:
    Jan 30, 2017
    Location:
    Vermont
    I just had my summer tires (on wheels) put on my 2016 LR4 (33000 miles) and the local indie replaced rear pads and rotors. They were below state inspection limits.
    Now, however, the car rolls like crazy at highway speeds and when I turn the wheel, for example turning onto the road and accelerating.
    Slight wiggling of the wheel gets the car rocking something scary at speed.

    I just got it back this PM.

    is this a mechanic screwup or the stability control gone bad? No warning light.

    I do get a “service needed in 100 miles” notice on startup but nothing else. What service could be needed? The manual doesn’t call for service at this mileage.

    Thank yoU
     
  2. avslash

    avslash Full Access Member

    Age:
    48
    Posts:
    868
    Likes Received:
    654
    Joined:
    Nov 22, 2011
    Location:
    The Lone Star State
    Sway bar drop links not tightened?

    you should not have had those off when doing the job, but that is the first thing I would look at if experiencing excessive body roll.
     
    Last edited: Jun 30, 2020 at 10:00 AM
  3. djkaosone

    djkaosone '11 LR4 HSE LUX 5.0L V8

    Posts:
    301
    Likes Received:
    177
    Joined:
    Oct 26, 2015
    Location:
    SoCal
    I concur, check your sway bar link. I noticed some excessive body roll after hitting a big mound at 40 mph Dukes of Hazzard style.

    Luckily, this was all that was damaged. Was still able to drive, but felt a little off.


    20200517_153740.jpg
     
    Jimmy Brooks and avslash like this.
  4. avslash

    avslash Full Access Member

    Age:
    48
    Posts:
    868
    Likes Received:
    654
    Joined:
    Nov 22, 2011
    Location:
    The Lone Star State
    Sent'er a little too hard...:)
     
    Jimmy Brooks and djkaosone like this.
  5. catman

    catman Full Access Member

    Posts:
    667
    Likes Received:
    171
    Joined:
    May 4, 2015
    Location:
    The Relay Shack, Parts Unknown USA
    It is not clear if these summer tires are new or ones you took off last year and the mechanic just swapped them back on. Did anyone check for any tire damage or the air pressures in the tires?
     
  6. Frank8

    Frank8 Full Access Member

    Posts:
    213
    Likes Received:
    43
    Joined:
    Jan 30, 2017
    Location:
    Vermont
    Thank you, everybody for sharing your knowledge.

    I took it back to mechanic (Northern Motorsport in Wilder Vermont) This AM.

    Haven’t heard back.

    The tires were the old summer ones, about 15k on them. On original factory rims. Take-off positions had been chalked marked. Rick the mechanic swears they were properly torqued, the pressures were spot-on. I checked.

    If I turn off the stability control the warning light goes on but handling is no worse. If I turn it back on the panel lite goes out and handling is no better. It seems as tho the stability control is inoperative irrespective of whether the panel light is on or off.

    Fortunately I still have 5 months on original warranty.
     

Share This Page